0

Lsp clangd does not recognise c++20 features in my Emacs. I use flycheck and it highlights something as

import <iostream>

std::format is not supported either and so on. Can someone tell me how to fix the issue?

1 Answer 1

1

This is not really a question about Emacs, but about clangd. The whole point of LSP, or the Language Server Protocol, is that it is a standard protocol editors can use to talk to Language Servers like clangd. Since there are many languages and many programs that act as language servers, all of them are configured differently. You will need to consult the documentation for clangd.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.