0

When I want to highlight the following region

(a ( b ( c ) ) ) )

I get

(a ( b ( c ) ) ) )

I mark the beginning and do forward-sexp (or sp-forward-sexp, which results in the same outcome)

In, insert mode, I get the desired outcome, but in normal mode I get the 2nd outcome.

I tried (evil-set-command-property 'sp-forward-sexp :keep-visual t)

(I remember it was hard to debug this, because hooks/advices are hard to track..)

1 Answer 1

0

https://www.dr-qubit.org/Evil_cursor_model.html

So vim has different model for cursor.

You can get the emacs behavior by removing the additional motion/visual cursor model.

by setting inclusive type equal to exclusive type.

I was trying to define new type

The fact that I coulnd't find how to fix this easily suggests that
evil mode is mostly for vim users not emacs users..

I thought i messed up my configuration, because it was hard to find any mention of the problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.