0

Noob question. I downloaded Doom Emacs following the installation instructions in the documentation. Now when I run the emacs command, it opens up the Doom Emacs window. Unfortunately, as I try interacting with the program with my keyboard, it continues typing in the terminal window. I can click around the application using my cursor, but am unable to use my keyboard.

I'm not running as the daemon or have it aliased in any other way.

4
  • 1
    Do you have the same issue when you run a vanilla Emacs with no configuration, using the emacs -q command ? Sep 6, 2023 at 18:18
  • Yes, it does the same thing. No input from the keyboard is working, just the cursor (which isn't very helpful). Sep 6, 2023 at 22:12
  • You have the command doom doctor to check out your installation. Try it. A second question: since doom uses evil mode, did you pressed first i or a to insert some characters?
    – Ian
    Sep 7, 2023 at 12:21
  • 1
    Are you using emacs-mac? If so I had the same problem and I resolved it by uninstalling emacs-mac and installing emacs-plus instead.
    – Steven Tay
    Sep 14, 2023 at 10:03

1 Answer 1

0

I had the same problem with emacs-mac both with and without the Doom Emacs cofig, but I don't think the emacs executable is supposed to work in this way.

This page has some examples of starter scripts: https://github.com/railwaycat/homebrew-emacsmacport/blob/master/docs/emacs-start-helpers.md

The following script worked for me:

#!/bin/bash
exec $(brew --prefix)/opt/emacs-mac/Emacs.app/Contents/MacOS/Emacs.sh "$@"

Installing emacs-mac with brew install emacs-mac --with-starter will create this script automatically instead of the emacs symlink. Then starting Emacs with emacs works without the input issues.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.