0

I have these settings in my init.el:

(global-display-fill-column-indicator-mode 1)
(setq-default fill-column 120)
(setq-default display-fill-column-indicator t)
(setq-default display-fill-column-indicator-character ?|)

But my fill column indicator is still a block, not a vertical line (|):

enter image description here

setq-default fill-column 120 takes effect so I'm sure init.el is loaded correctly. But no matter how I set display-fill-column-indicator-character nothing changes.

I'm on Windows if that matters.

Edit:

This is the culprit:

(use-package emacs
  :config
  (load-theme 'modus-vivendi)) 

But I don't understand how. I set display-fill-column-indicator-character after I load the theme, but it still doesn't take effects.

3
  • Did you test it with other custom configs disabled (emacs -q)?
    – Y. E.
    Commented Sep 6, 2023 at 10:55
  • @Y.E. Thank you. I didn't know about this (it's my first day using Emacs). It seems that the ``'modus-vivendi` theme is causing the problem. But I don't understand how it works: I set display-fill-column-indicator-character after I apply the theme. Why isn't it still taking effects? Commented Sep 6, 2023 at 11:29
  • You're welcome. See modus-vivendi docs for a starter and maybe try tweaking line-spacing.
    – Y. E.
    Commented Sep 6, 2023 at 16:58

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.