0

I want to start learning Common Lisp and I want to use portacle for an IDE-like experience.

As I understand, portacle doesn't provide a normal init.el configuration file. Instead, it uses a file in the /config/ folder called user.el.

I tried to get started by adding this to my config:

;; Set up package.el to work with MELPA
(require 'package)
(add-to-list 'package-archives
             '("melpa" . "https://melpa.org/packages/"))
(package-initialize)
(package-refresh-contents)

;; Download Evil
(unless (package-installed-p 'evil)
  (package-install 'evil))

;; Enable Evil
(require 'evil)
(evil-mode 1)

which fetches the contents from the evil-repository with MELPA.

This didn't work though. When I do this I get: failed to download MELPA archive and a similar error as below: GNU-TLS error. I'm right away in the scratch buffer and I can't see the CL-USER-command prompt anymore either..

I also tried to install evil with package-install RET evil RET, but all I got was a

GNU-TLS error: #, -12

So my question here: How do I get started with evil-mode? I really don't intend to learn the emacs bindings.

3
  • In case no answer can be found to the question. It has been surprisingly easy to set up the common lisp Sly-IDE in doom emacs. Maybe I'll use that instead. Sep 19, 2023 at 12:11
  • "In case no answer can be found to the question." -- You can email the author of Portacle or open an issue for help.
    – shynur
    Sep 19, 2023 at 14:45
  • @shynur Ok I'll consider it. Sep 19, 2023 at 22:11

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.