0

When the variable org-export-preserve-breaks is t, the org contents...

text
\[
a + b + c
\]
text

gets exported to LaTeX as...

text\\[0pt]
\[
a + b + c
\]\\[0pt]
Text\\[0pt]

This adds a lot of extra padding to the equation in the pdf. Is there a way to avoid adding the latex-line-break-safe sequences to the exported LaTeX while keeping the variable set to t?

1 Answer 1

0

Docstring of the user option org-latex-line-break-safe says that [0pt] protects the following [...] from being interpreted erroneously.

So, probably start with setting this user option value to an empty string, but watch out for possible errors.

(setq org-latex-line-break-safe "")

If that doesn't work, read this org mailing list discussion and then, if the issue still isn't resolved for you, M-x org-submit-bug-report.

1
  • I think that would essentially be the same as setting org-export-preserve-breaks to nil. Would there be a way to define an export filter which targets these regions instead?
    – user41177
    Sep 22, 2023 at 15:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.