0

I installed spacemacs in a folder hierarchy as below

enter image description here

enter image description here

I run it through this bat file

set HOME=%~dp0/.spacemacs
Set VAR = %cd%
"%cd%\bin\runemacs.exe"  --insecure --debug-init

It runs quite OK (it launches and start updating) BUT the package spacemacs-editing-visual ask for git program

Debugger entered--Lisp error: (file-missing "Searching for program" #("No such file or directory" 0 25 (charset windows-1252)) "git")
  call-process("git" nil #<buffer  *temp*> t "version")
  apply(call-process "git" nil #<buffer  *temp*> t "version")
  process-file("git" nil #<buffer  *temp*> t "version")
  apply(process-file "git" nil #<buffer  *temp*> t "version")

I cannot add git.exe to PATH variable in windows as I do not have admnistrator rights, but I have git downloaded

I already tried to :

  • add git.exe to emacs bin folder
  • add this to init.el
(setenv "PATH" (concat "C:/Users/JulienFERNANDEZ/OneDrive/Portable Softwares/Git/bin;" (getenv "PATH")))

But it is not working

2
  • Setup your PATH in .spacemacs.env. The initial environment that Spacemacs sees is defined in that file.
    – g-gundam
    Sep 28, 2023 at 9:34
  • 1
    thank you, I did not know Sep 29, 2023 at 7:08

1 Answer 1

0

You can set user-level environment variables without admin rights.

Optionally, you can modify PATH only to be seen by Emacs by putting the following line in your .bat file.

set PATH=%PATH%;C:/.../Git/bin
1
  • adding "PATH = ... " in bat file works well ! Thx ! Sep 29, 2023 at 7:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.