1

I am trying to use company-completion within a Yasnippet header. I bound company-complete to C-SPC and use that for my auto-completion. When I hit control enter, I get a screen like this: enter image description here

And I hit enter to get this:

Then I start typing iost- and wait to get the company-complete (It breaks immediately when I hit C-SPC, see below):

And then I hit enter to complete, and this happens: (or immediately if I hit C-SPC):

I tried googling around but no solution worked. I only want to be able to yasnippet snippets from the company-complete dropdown if that's possible.

Thank you!

  • Maybe you would find my answer emacs.stackexchange.com/a/7925/5368 to another question useful. I use tab as my binding for both company and yasnippet, but probably it can be adapted to C-space... – Kristóf Marussy Feb 4 '15 at 16:45
  • Thank you kristof! That seems to work very well. I still get this bug on the header files but it works fine everywhere else. Thank you! – davess Feb 6 '15 at 0:09
  • You could try reporting that bug on Company's issue tracker. – Kristóf Marussy Feb 6 '15 at 12:47
  • @davess You really should report this to the issue tracker, but please include the minimal necessary configuration to reproduce the problem. – Dmitry Feb 11 '15 at 1:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.