0

I upgraded a few months ago to Emacs 29.1. Everything appeared to work until I tried to open Emacs from a terminal.

Here is the error message

Warning: arch-independent data dir 'c:/Program Files/Emacs/x86_64/share/emacs/27.2/etc/': No such file or directory
Warning: Lisp directory 'c:/Program Files/Emacs/x86_64/share/emacs/27.2/lisp': No such file or directory
Error: c:/Program Files/Emacs/x86_64/share/emacs/27.2/etc/charsets: No such file or directory
Emacs will not function correctly without the character map files.
Please check your installation!

It appears that the terminal isn't aware of the upgrade from version 27.2 to 29.1. How do I finish the installation of 29.1?

5
  • How did you upgrade Emacs?
    – shynur
    Nov 3, 2023 at 1:56
  • Is this a Windows-native terminal and shell? (And if not, what are you using?)
    – phils
    Nov 3, 2023 at 3:25
  • if you run 'emacs --version' in terminal? Seem it still run old emacs exe but it's partialy uninstalled? Nov 3, 2023 at 9:42
  • I used the windows installer from gnu.org to install 29.1. Nov 6, 2023 at 18:31
  • I'm using the Windows terminal app. I tried running emacs --version in the terminal and now find that I've created a new problem. Now the error is "not recognized as a cmdlet..." I had changed the path thinking that was the problem. Same behavior in the emacs shell and the windows shell. Nov 6, 2023 at 18:40

1 Answer 1

0

The problem was the path variable. I changed the path to point to the location of emacs.exe C:\Program Files\Eamcs\emacs-29.1\bin.

I can open emacs from a windows terminal now.

Thank you commenters. I couldn't have solved the problem without your comments.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.