This page of ergoemacs-mode documentation tells about ergoemacs-theme-option-on function that can disable some optional keybindings. When I try to use this function emacs throws an error. Besides this ergomacs-mode works correctly.

Here is my config:

(require 'ergoemacs-mode)
(setq ergoemacs-theme nil)
(setq ergoemacs-keyboard-layout "us")
(ergoemacs-theme-option-on '(guru no-backspace))
(ergoemacs-mode 1)

Here is error message:

Debugger entered--Lisp error: (void-function ergoemacs-theme-option-on)
  (ergoemacs-theme-option-on '(guru no-backspace))
  funcall-interactively(eval-last-sexp nil)

Is there any way to enable this theme options?

  • 1
    You might have written an extra s or missed one: ergoemacs-theme-option_s_-on
    – shynur
    Nov 7, 2023 at 15:41
  • @shynur Thanks, I've messed up with 's' while was writing this question. In docs there is only ergoemacs-theme-option-on. Anyway it produces the same error. I'll edit my question to avoid further confusion.
    – almint
    Nov 7, 2023 at 16:08

1 Answer 1


Try reading the ergomacs documentation inside of Emacs, instead of via the web. This will ensure that you are reading the documentation that came with the package as it is installed, instead of for a different version that has added, removed, or changed some commands. I don’t have ergomacs installed, but presumably it comes with an info manual that you can read with C-h i. If that manual also mentions a command which doesn’t actually exist, perhaps it is simply a defect in the manual that you should report to the author.

You could also read through the ergomacs source, specifically looking at the names of the commands that it defines. You may find that the command has been renamed, or that there is some other obvious way to enable a feature that you can use.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.