3

Q: how can I get TeX-command-master (C-c C-c) to default to LaTeX rather than View?

TeX-command-master dispatches to various commands, such as LaTeX, BibTeX, View, etc., almost none of which I use besides LaTeX and BibTeX. In particular, I almost never use View via TeX-command-master (using TeX-view via C-c C-v instead), and it's annoying that TeX-command-master defaults to View after running LaTeX.

Instead, I'd like TeX-command-master never to default to View, but rather to LaTeX so that I can recompile without breaking my flow.

How would one change the default? It seems rather extreme to edit out the View option from TeX-command-list, and I'm not sure where else to look.

4

The variable controlling the default operation to do when AUCTeX assumes the output file is ready is TeX-command-Show. The default value is of course "View", but in your case you want to set it to "LaTeX".

  • Unfortunately, that does not seem to change the behavior -- I've set it to LaTeX, but still get View as the default. – Dan Feb 4 '15 at 17:17
  • Did you restart Emacs? – giordano Feb 4 '15 at 20:14
  • Yup, you're right. Starting a fresh session did the trick. – Dan Feb 4 '15 at 20:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.