0

I suspect that I accidentally entered some key combination that change the behavior of dead keys in emacs: when I use a Spanish keyboard layout with dead keys, when I used to enter an apostrophe (') for example, it would allow me to enter an "a" afterward to give me 'á', or a space to give me a literal apostrophe. Now all of a sudden it gives me a popup showing the accent, and if I then enter an "a" nothing happens (see screenshot).

  • I did not have any specific input method defined.
  • This only happens in emacs, not for example in pluma (text editor) or in this browser window.
  • This happens even with emacs -Q
  • When using a US keyboard layout (without dead keys), everything works as always.

Does anyone know what could have happened and how I can go back to the old behavior?

emacs with dead character popup

8
  • Please use emacs -Q for your recipe, and say that in the question. If you can't repro the problem/question from emacs -Q then bisect your init file to find the culprit. Thx.
    – Drew
    Commented Jan 24 at 16:54
  • 1
    It happens even with emacs -Q. I wonder if it is something of my desktop environment that somehow only affects emacs...
    – doetoe
    Commented Jan 24 at 17:17
  • Say in the question that it happens with emacs -Q. Questions need to stand on their own; comments can be deleted at any time. Thx.
    – Drew
    Commented Jan 24 at 18:14
  • What is your OS and desktop environment? I've seen similar questions (which I can't find right now, sorry) about OS features that behave like this (although the fact that it's not happening outside of Emacs is interesting, so it may or may not be the same thing).
    – phils
    Commented Jan 24 at 23:57
  • reddit.com/r/emacs/comments/11axtqd/weird_popup_when_pressing_m and reddit.com/r/emacs/comments/vkviqk/… are what I was thinking of, in case those help.
    – phils
    Commented Jan 25 at 7:24

1 Answer 1

1

As mentioned in the Emacs Wiki and pointed out in other answers to this question (e.g. here on StackExchange), starting up emacs after disabling ibus (or SCIM) with a command line like this typically helps:

$ XMODIFIERS='' emacs

If the problem persists you might also want to check whether it makes a difference to invoke emacs from the command line as opposed to using a GUI launcher. The environment variables (also look at locale settings, for example) might turn out to differ which, again, might explain the different dead key behavior.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.