0

Followed these steps:

  • Downloaded emacs-26.3.tar.gz, drop it in a subdir of my home dir
  • cd to there
  • tar -xvf emacs-26.1.tar.xz
  • Seems happy a bunch of files appear
  • cd emacs-26.3
  • ./configure --prefix=/home/<my_home_dir>/.local/share/emacs --with-gif=no --with-tiff=no --with-x-toolkit=no --with-jpeg=no --with-png=no --with-gnutls=no

Config errors saying
The required function 'tputs' was not found in any library and it lists the 5 libs it tried.

libtinfo libnurses libterminfo libcurses libtermcap

  • ran >sudo apt install for those five and it errors saying
    unable to locate package.

It looks like sudo can't find them.

I don't have public internet on the machine I am installing on

1
  • Are you sure configure ran happily? After I run configure, the Makefile has been created Feb 6 at 17:30

1 Answer 1

0

It seems like the problem was missing ncurses.
Ran sudo apt install ncurses-dev and config runs well enough to generate a make file.

I still needed the --with-xxx=no options for all of those graphics packages as part of running configure.

Then was able to run make and have emacs 26.3 up now

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.