0

I need to setup lsp to work on LaTeX file in a remote machine. I installed texlab both in local and in remote machine and add the path to the remote texlab in my emacs (spacemacs) init file as follow:

  (with-eval-after-load "tramp" (add-to-list 'tramp-remote-path "~/.cargo/bin"))
  (setenv "PATH" (concat (getenv "PATH") ":~/.cargo/bin/"))
  (setq exec-path (append exec-path '("~/.cargo/bin/")))
  (require 'lsp-latex)
  (setq lsp-latex-texlab-executable "~/.cargo/bin/")

  (with-eval-after-load "tex-mode"
    (add-hook 'tex-mode-hook 'lsp)
    (add-hook 'latex-mode-hook 'lsp))

I still get this from lsp: LSP: The following servers support current file but do not have automatic installation: texlab-tramp. Command "texlab" is not present on the path.

Do you have any suggestion?

1 Answer 1

0

tramp-remote-path might be cached, so I recommend to apply M-x tramp-cleanup-all-connections.

The last entry in exec-path shall be exec-directory, so you must add your directory differently. Something like

(setq exec-path (cons "~/.cargo/bin/" exec-path))

However, I'm not sure it is used for remote processes. If everything fails, write a message to [email protected], perhaps we could help you there.

2
  • nothing changes, still the same error
    – Riccardo
    Commented Feb 8 at 13:23
  • FTR, after discussion on the Tramp ML it turns out to be a configuration problem at user side. Commented Feb 13 at 12:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.