0

I recently moved my Org Roam directory to a new machine. However, creating new nodes with org-roam-node-find fails with the error message run-hooks: Symbol’s function definition is void: org-tempo-setup. I tried running org-roam-db-clear-all and then org-roam-db-sync but it doesn't fix the issue.

Browsing and reading existing nodes works fine though.

Here is my config for Org-Roam:

;; Org roam setup
(use-package org-roam :ensure t)
(setq org-roam-directory "~/Desktop/secbrain")

(org-roam-setup)

Why am I seeing this error message?

5
  • Add (require 'org-tempo) to your init file.
    – NickD
    Feb 26 at 18:58
  • Thank you. So the org-tempo error is gone but now I get this error run-hooks: Symbol’s value as variable is void: org-mouse-features
    – leonardo
    Feb 26 at 19:02
  • Add (require 'org-mouse) to your init file.
    – NickD
    Feb 26 at 20:27
  • This solved the problem. Do you know why I have to add these things manually?
    – leonardo
    Mar 2 at 10:42
  • 1
    Presumably, you had them on the old machine: you probably installed them when you set up the hook that is now complaining, then you forgot about it. Both of these packages are optional, so you have to add them to your emacs session if you want to use them - just like any other library that is not set up for autoloading. Correction: actually org-mouse seems to be automatically loaded even if I start with emacs -Q so if your version were recent enough, you probably would not need to require it any more.
    – NickD
    Mar 2 at 11:15

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.