0

After a fresh install of Emacs and Doom, the program hangs after attempting to open a file from the mini-buffer.

I've been trying to set up doom emacs for the first time on a newly installed Fedora OS. After following all of the proscribed steps, the very first thing I did was opening my config file as shown below.

Attempting to open my config file moments before pressing the return key

However, after pressing the return key to open the file, the cursor seems to go the beginning of the line instead of executing a command. This hangs the program and does not respond until I force kill it from system activity.

Cursor frozen at the start of the line

I have tried using doom doctor, doom clean, doom build, doom sync, etc. I've done several wipes fresh installs of Emacs and doom to no avail. Each time the same behavior shows up.

The doctor will see you now...

> Checking your Emacs version...
> Checking for Doom's prerequisites...
> Checking for Emacs config conflicts...
  ! Found another Emacs config: ~/.config/emacs (directory)
    Having multiple Emacs configs may prevent Doom from loading
    properly. Emacs will load the first it finds and ignore the rest. If
    Doom isn't starting up correctly (e.g. you get a vanilla splash
    screen), make sure that only one of these exist.
    
    Chemacs users may ignore this warning.
> Checking for missing Emacs features...
> Checking for private config conflicts...
> Checking for common environmental issues...
> Checking for stale elc files...
> Checking for problematic git global settings...
> Checking Doom Emacs...
  ✓ Initialized Doom Emacs 3.0.0-pre
  ✓ Detected 44 modules
  ✓ Detected 141 packages
  > Checking Doom core for irregularities...
    ! "NFM.ttf" font is not installed on your system
      Some needed fonts are not properly installed on your system. To download and
      install them, run `M-x nerd-icons-install-fonts' from within Doom Emacs.
      However, on Windows this command will only download them; the fonts must be
      installed manually afterwards.
  > Checking for stale elc files in your DOOMDIR...
  > Checking your enabled modules...

I can't fix the font because for some reason the git request seems to hang. Here is my ~/.config/emacs directory. I can't tell what's not supposed to be in there if anything.

.  ..  bin  .dir-locals.el  docs  .doomrc  early-init.el  .git  .github  .gitignore  LICENSE  lisp  .local  modules  profiles  README.md  shell.nix  templates

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.