1

Since today, I've been experiencing freezes of my emacs/AucTeX config. I'm using Ubuntu 22.04 with emacs 27.1 (if important, i3 and fizsh as defaults).

The freeze happens when I press C-c C-c Enter (to build the current buffer with a TeX file in LaTeX/PS major mode) where I use Enter to choose the default command "LaTeX". The pointer moves to the left end of the minibuffer and Emacs freezes entirely, without reacting to C-g. After restarting emacs, I was able to reproduce the freeze at the exact event several times.

To rule out configuration errors, I've deinstalled custom packages, removed my .emacs.d directory as well as my .emacs file. I've reinstalled emacs, texlive.

Then, I tried building a minimal .tex file using emacs' plain pdflatex functionality. That worked.

But, then, I reinstalled AucTeX 14.0.3 from elpa (inside emacs), tried again, same freeze.

I'm reading here about that it could be that emacs 27.1 might be too old for current AucTeX.

Update: In the meanwhile, I've manually backported to AucTeX 13.3 (from Jan 17) and the problem has gone. One downside of this is that switching forward to AucTeX 14.0.3 again does not allow me to reproduce the freeze, but instead, I now get the error message described here when performing the same action. Something must have changed using make install/uninstall that at least avoids the freeze.

Update 2: In the meanwhile, I've updated my whole Linux distribution, now using Emacs 28.2 and AucTeX 14.0.4 (from melpa), again all is working fine, even with my old .emacs settings.

1
  • 1
    Can you please do: Uninstall the older AUCTeX via package interface, close all Emacs instances, restart Emacs and install the latest AUCTeX version via package interface. Close and start Emacs as emacs -Q, then in *scratch* buffer, eval the following (progn (setq debug-on-error t) (package-initialize t) (package-activate 'auctex)) (i.e., set the cursor after the last ) and hit C-x C-e) and then open your .tex file and try it again? Also do M-x list-load-path-shadows RET to check you don't have any other AUCTeX installation/files sitting on your HD. Mar 11 at 8:00

1 Answer 1

1

I think you're facing two different issues:

Updating AUCTeX from 13.x to 14.x:

There were some internal changes in AUCTeX, and supposing that you're using the package interface provided by Emacs, you have to:

  • Make sure you don't have multiple AUCTeX installations (M-x list-load-path-shadows RET)
  • Uninstall the 13.x installation (M-x list-packages RET ...)
  • Close the current Emacs session and restart Emacs
  • Install the 14.x version (M-x list-packages RET ...)

Issues reported here and probably here

AUCTeX now requires Emacs 27 and higher. There was a change in AUCTeX to use the :local tag inside defcustom instead of make-variable-buffer-local. The implementation in Emacs 27.1 was faulty and was fixed for Emacs 27.2. This issue is now resolved with AUCTeX 14.0.4 by reverting the usage of :local tag, therefore, things should be back to normal state.

1
  • Thanks, @ArashEsbati for these hints. I'm in preparation for updating my aged machine, so, hopefully, the correct(ed) combination will get installed. It's, however, good to know that potentially several issues have been at play in my setting, not just misconfiguration :)
    – mfg
    Mar 18 at 19:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.