0

Killing commands, such as kill-word, have started to erase text in read-only buffers. For example, invoking kill-word in dired-mode or mu4e-headers-mode will delete words from a filename or from an email subject, respectively. This has no destructive effects: the files/emails/etc are not themselves affected. Does anyone know what might be causing this behavior?

All my attempts to diagnose it have failed. I tried to bisect the init file, but the issue does not occur immediately after restarting; it happens only after 5–15 minutes of starting the new session, making bisection infeasible.

5
  • "have started to" -- Do you see the same thing starting from emacs -Q (no init file)? If not, bisect your init file to find the culprit. If yes, provide a step-by-step recipe to repro (from emacs -Q).
    – Drew
    Mar 25 at 14:08
  • No, I don’t experience the issue with emacs -Q. Unfortunately, I tried to bisect the init file, but the issue does not occur immediately after restarting; it happens only after 5–15 minutes of starting the new session, making bisection infeasible. That’s why I thought of asking here whether anyone had thoughts on what might be causing it.
    – Pablo
    Mar 25 at 17:15
  • Put all such info in the question itself. Comments can be deleted at any time; questions need to stand on their own. Thx.
    – Drew
    Mar 25 at 18:25
  • 2
    My first guess is that something in your config is doing bad things with inhibit-read-only (which should only ever be bound with some very specific limited scope).
    – phils
    Mar 25 at 21:15
  • 1
    @Drew: done. @phils: thank you! I see that inhibit-read-only is set to t, so with debug-on-variable-change I should be able to identify the package that is setting its value.
    – Pablo
    Mar 26 at 0:29

1 Answer 1

1

This was caused by the package consult-mu, which sets the value of inhibit-read-only to t globally. Reported here.

Thanks to phils for helping me diagnose the issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.