0

Running preview-latex in Emacs 25 on Ubuntu 18.04 once worked for me, but now inserts warning icons instead of rendered images of the formular snippets.

A minimal example, which doesn't work is:

\documentclass{article}
\begin{document}
$a = 1$
\end{document}

I carefully read the preview-latex manual on https://www.gnu.org/software/auctex/manual/preview-latex.html which mentions issues with gs < version 9.27 on https://www.gnu.org/software/auctex/manual/preview-latex.html#Known-problems.

The combination of tools used by preview-latex to generate preview image snippets is not trivial and indeed, I don't see any preview.dsc or *.png files generated by it on my setup.

Ubuntu 18.04 ships with gs version 9.26, but the solution suggested in preview-latex's section on known issues doesn't work, because the preview-pdf-adjust-color-method variable doesn't exist on Emacs 25.

Which additional diagnostics could I run to pin down the problem?

3
  • Which version of AUCTeX are you using, and how did you install it? Commented Mar 26 at 14:45
  • My AUCTeX version is 11.91 (installed as an Ubuntu package). Commented Mar 29 at 18:17
  • 11.91 is about 7 years old. Uninstall that package and install AUCTeX from ELPA with M-x list-packages <RET>, mark the auctex package for installation with i, and hit x to execute the installation procedure. You should get the version 13.2.4. If that doesn't work, download the tarball, uncompress and use M-x package-install-file RET to install it. Commented Mar 31 at 15:05

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.