I am on Debian 12 / Ubuntu 22.

I installed emacs+ess by doing

sudo apt install emacs sudo apt install ess

When I start an R file, it does not show me the icons for instance for Load file.

Can someone please point me in the right direction? What can I do to fix this?

Here is a screen shot:

ESS without load file buttons

On Debian 10, my ESS menu bar looked like this :

ESS in Debian 10

  • What is the value of ess-use-toolbar?
    – Tobias
    Apr 4 at 13:27
  • Can you try M-x load-library <RET> ess-toolbar <RET>?
    – Tobias
    Apr 4 at 15:43
  • M-x load-library <RET> ess-toolbar <RET> did not bring back the buttons. Apr 4 at 16:17
  • Please do M-x customize-option <RET> ess-use-toolbar <RET>. What does the customization buffer for ess-use-toolbar show? Is it switched on or off?
    – Tobias
    Apr 4 at 16:47
  • When I do M-x customize-option <RET> it prompts for Customize variable. When I type in ess-use-toobar and press <RET> it says [No match]. Apr 5 at 4:18

1 Answer 1


To get this

ESS-specific Toolbar Icons in Toolbar

ESS-specific Toolbar Icons in Toolbar

do this

;; Recipe for `emacs -Q`

(setq package-user-dir "~/.emacs.d/elpa")

(use-package ess-toolbar
  :autoload ess-add-toolbar)

(use-package ess-r-mode
  (ess-use-toolbar t)
  (ess-toolbar-global nil)
  (add-hook 'inferior-ess-r-mode-hook
            (defun my-inferior-ess-r-mode-hook-20240405113534003 ()

  • Dear mxnt, many thanks for your reply. I pasted all except the first 2 lines of the lisp code in my .emacs. Now I can see the buttons which were missing. Apr 5 at 9:07
  • I have a small related query. Why do I need to do this manually as of now? If I remember correctly, in the earlier versions of Debian the buttons would show up on their own. Apr 5 at 9:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.