0

I want to install a theme library, the package is already installed but emacs does not recognize it. I have already installed the melpa packages and the gnu packages, as shown in the code below:

(add-to-list 'package-archives '("melpa" . "https://melpa.org/packages/") t)
(setq package-archives '(("gnu" . "http://elpa.gnu.org/packages/")
                         ("marmalade" . "http://marmalade-repo.org/packages/")
                         ("melpa" . "http://melpa.milkbox.net/packages/")))

This started happening today, I already researched and didn't find solutions, just a post on stackoverflow which is where I got this code above, I'm new to emacs, I'm still learning how to use it so I have no idea how I can solve it.

The error message says: package-install RET doom-themes RET no match. What can I try to resolve this error?

8
  • If you setq, you clobber the old value of the variable with the new value, so the second line completely obliterates what the first line did. The code you got is probably wrong: where did you get it?
    – NickD
    Commented May 17 at 20:07
  • @NickD I got it from stackoverflow in an old post Commented May 17 at 20:42
  • Link to the post please?
    – NickD
    Commented May 17 at 21:53
  • See melpa.org/#/getting-started for instructions and don't muck around with setting package-archives: add to the existing value as shown in the instructions.
    – NickD
    Commented May 17 at 21:56
  • @NickD emacs.stackexchange.com/questions/2490/… Commented May 17 at 23:15

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.