1

I'm working with very large tables (14 columns for example) and it's really difficult to find the right cell to edit.

I discovered the align-current command and tried to use it on my table, but the result is still not very helpful: In Aquamacs, it looks like that:

enter image description here

  • the red signs are the "&" characters, which separate the table columns. Ideally they should be placed on straight vertical lines, but you can see that they don't in my case

However, if I copy the text into another text editor, it looks properly aligned:

enter image description here

I wonder if it is a problem with the font used in emacs, describe-font in my .tex buffer gives

name (opened by): -apple-Monaco-medium-normal-normal--12----m-0-iso10646-1 full name: Monaco size: 12 height: 17 baseline-offset: 0 relative-compose: 0

I thought that Monaco is a monospaced font, so that should not be the problem, or could it?

  • 3
    Doesn't look monospaced in your screenshot. Switch to one you're sure is monospaced in order to check. – Dan Feb 16 '15 at 14:44
  • 2
    Monaco is a monospaced font, but the font in your screenshot doesn't look like Monaco (specifically the OSX typeface designed by Kare and Holmes). The is and ls in your screenshot do not have serifs, making them thinner than other letters. – Matthew Piziak Feb 16 '15 at 17:49
  • @Dan : thanks, you both were right! Aquamacs seems to have its own font definitions by default. See my answer below. – MostlyHarmless Feb 17 '15 at 10:28
2

Thanks, @Dan and @Matthew Piziak for your help!

Indeed, Aquamacs seems to have its own font definitions:

Switching to a mono-spaced (fixed pitch) font throughout Aquamacs uses a mono-spaced font (Monaco) as a default, but uses the system’s variable-width font (Lucida Grande) for all text modes, including those derived from ‘text-mode’.

To use a monospaced font throughout (or the same font everywhere), just disable ‘aquamacs-autoface-mode’ by selecting Options → Appearance → Auto Faces → Auto Faces. Save your options. You may then choose another font via Options → Appearance → Font if you so desire.

Alternatively, if you would just like to customize specific fonts, see the next frequently asked question.

source: http://www.emacswiki.org/emacs/AquamacsFAQ#toc10

I did as described and disabled the autoface-mode and after a restart of Aquamacs, the table looks really aligned:

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.