10

The fonts in my pdf's as displayed in doc-view aren't particularly readable. Is there a setting I can change to improve the image quality? I tried changing doc-view-resolution from 100 to 300, but that just made the pdf render larger.

6

If by "render larger" you mean that the dimensions of the rendered png image are larger, then you could use some of the doc-view functions to fit the image to your window: doc-view-fit-page-to-window, doc-view-fit-width-to-window, and doc-view-fit-height-to-window.

In other words, increase the resolution of the rendered image as you did, and then fit (probably shrink) the sharper image with the ...-fit-... functions.

  • sadly, these commands don't appreciably improve the rendering quality. This is especially noticeable for figures. – wdkrnls Oct 17 '14 at 18:23
  • 1
    It turns out that doc-view was rendering the PDF fine. The PDF output from LaTeX was just really low quality. – wdkrnls Oct 28 '14 at 17:09
  • @wdkrnls so how did you improve on it? Asking because it seems I have the same problem – pandita Apr 6 '17 at 14:04
  • For the resolution change to take effect one first has to kill all buffers displaying the pdf and run doc-view-clear-cache. – dangom Nov 13 '17 at 15:26
  • Note that solution with 'doc-view-resolution' works only when doc-view-scale-internally is on and imagemagic support is enabled. Otherwise Emacs does rescaling by changing doc-view-resolution to a lower value. – Artem Pyanykh Mar 5 at 8:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.