1

This question already has an answer here:

Out of nowhere in the past couple days, running M-x list-packages has started requiring me to select a coding system because of Chinese(?) characters in the buffer. Selecting the default, utf-8, works just fine. How can I avoid needed to select a coding system when trying to update my packages?

marked as duplicate by Malabarba Feb 26 '15 at 22:38

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Does this reproduce for you in emacs -Q? – PythonNut Feb 26 '15 at 20:02
  • @Ryan does (set-default buffer-file-coding-system 'utf-8) help at all? – PythonNut Feb 26 '15 at 22:04
  • @PythonNut I also had this problem.. I checked my Emacs init file, and yes there was a line with (set-language-environment "Latin-1") after commenting this line out, I do not get the question the question any more.. – Håkon Hægland Feb 27 '15 at 9:42

Browse other questions tagged or ask your own question.