2

Trying to use Emacs in MS Windows (operating system), which I acknowledge is not ideal. However, whenever I attempt to use the Meta key the tiled start menu appears serves as a disruption and makes Emacs unusable. Is there a way of either disabling this feature or re-assigning the key?

  • 1
    Odd. For me the Windows key brings up that menu, Alt does not. – glucas Feb 28 '15 at 20:05
  • 1
    This question appears to be about Windows rather than Emacs per se. – Dan Mar 2 '15 at 2:13
  • @Dan There are solutions to the problem from both the windows side and the emacs side. Just because a problem involves interacting with another piece of software doesn't make the question off-topic. If that were the case, the entire site would be doomed. – Sean Allred May 12 '15 at 4:59
3

With emacs -Q (no init file), the Meta key should work normally on MS Windows - no problem.

However, I think what you are referring to is the fact that Windows grabs certain Alt (hence Meta) keys for its own use, so that Emacs never sees them.

There is an Emacs function, w32-register-hot-key, that you can use, to take care of this - you just "register" whatever key bindings you like as being for Emacs, not Windows.

For example, this makes Windows pass M-tab and M-S-tab to Emacs:

(when (fboundp 'w32-register-hot-key)
  (w32-register-hot-key [M-tab])
  (w32-register-hot-key [M-S-tab]))

However, for 64-bit Windows 7 at least, this option no longer has any effect.

0

This is unusual behavior. Normally the Windows key brings up the start menu, and Alt on its own does nothing. Nevertheless, if you find you need to rebind your keys, you can do so using the free program SharpKeys. Using registry keys it can rebind any key on your keyboard.

You may just want to figure out what program is causing the Alt key to behave this way.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.