17

I have started using Org-Mode and every time I close my file every headline is collapsed when I reopen it. Is there any way to stop that? I want every headline fully expanded.

5
  • 4
    (setq org-startup-folded nil)
    – lawlist
    Commented Mar 1, 2015 at 17:50
  • 1
    Your question heading and body are opposite. Do you want or don't want the full expansion at start-up? Commented Mar 1, 2015 at 17:55
  • @kaushalmodi -- If you could please add the alternative approach to your answer -- i.e., (setq org-startup-folded nil) -- that would be greatly appreciated. One answer is sufficient. I added a 1+ as to your request for clarification from the original poster.
    – lawlist
    Commented Mar 1, 2015 at 17:56
  • @kaushalmodi sorry my bad! I will edit!
    – Adam
    Commented Mar 1, 2015 at 18:01
  • The default was changed recently, so that (unless you specify otherwise) all the headlines are expanded: that was deemed friendlier to beginners, while old-timers (or people who have read this question and/or the relevant section of the manual as in Kaushal's answer) know what to do to change it if they don't like it.
    – NickD
    Commented Oct 8, 2020 at 19:38

1 Answer 1

21

It is possible to set the Initial Visibility per org file. You can make the org file show all the headings expanded at start-up by using

#+STARTUP: showeverything 

As @lawlist mentioned in the comments, you can also set this option to be effective globally by putting the below in your emacs init:

(setq org-startup-folded nil)
0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.