0

I have been using Emacs 24 on Windows 7 for almost a year without any issues. But recently, kill-ring in my Emacs has stopped synchronizing with clipboard (actually whatever I copy from within Emacs is available in system's clipboard but not other way around). I've successfully used Shift + insert to paste things off my clipboard all the time earlier but not any more :(. I've tried adding lines below to my Emacs init script.

  (setq x-select-enable-clipboard t)
  (setq x-select-enable-primary nil)
  ;; Treat clipboard input as UTF-8 string first; compound text next, etc.
  (setq x-select-request-type '(UTF8_STRING COMPOUND_TEXT TEXT STRING))

But it has not affect on the erroneous behaviour of synchronization between kill-ring and clipboard. Any help or suggestions or guidance to debug the issue would be appreciated.

Notes

  1. I'm using arsclip as clipboard manager.
  2. I'm running Windows 7 x64 and emacs-w64.
  3. I use conemu, I noticed that my clipboard is no synchronizing both ways.
  • Did it work with stock Emacs without any configuration? I can copy/paste both ways fine. Probably you should disable 3rd party apps that manage your clipboard to see whether it works again or not?L – Tu Do Mar 4 '15 at 4:15
  • I tried running stock Emacs with no customization, also disabled my clipboard manager but it still persists. – Shivam Mar 4 '15 at 4:54
  • Have you tried C-y instead of S-insert? – Malabarba Mar 4 '15 at 9:34
  • Yes. I've checked browsed kill-ring within Emacs, but the text I copied on windows does not exist. But, if I copy something within Emacs then it appears on the kill-ring. – Shivam Mar 4 '15 at 9:43
  • Are you running Emacs in GUI or in terminal? It seems like you are running Emacs in that Conemu terminal? If so, you should run GUI Emacs and it should work like normal desktop app. – Tu Do Mar 6 '15 at 12:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.