2

Problem:

For some mysterious reason, when I open a link in firefox, a new firefox instance opens. Also note instead of the content of the link, my home-page shows up.

Instead I would like a new tab to open in my running instance and actually show the content of the link.

but I would like to make it work for firefox?

I am running Fedora Linux 21, with emacs 24.4.1.

Troubleshooting:

1) If I set my browser to chrome/eww, then it works:

(setq browse-url-browser-function 'browse-url-generic
      browse-url-generic-program "google-chrome")

2) I tried loading my emacs with emacs -q and dissabling all firefox plugins, but the result was the same.

EDIT: Solution:

As per post below, I rebuild emacs from sources and that solved the problem.

In case anyone reads this, I wrote a blog entry on how to rebuild emacs on fedora: https://coffeeorientedprogramming.wordpress.com/2015/03/11/how-to-compilebuild-emacs-from-scratch-on-fedora/

For Ubuntu: http://ergoemacs.org/emacs/building_emacs_on_linux.html

1 Answer 1

5

This is due to a Firefox upgrade that changed the command line parameters. It's fixed in both trunk and emacs24 git branch.

2
  • Thank you for your reply. I had to figure out how to rebuild emacs from sources, but once done the issue is fixed. Thank you . Commented Mar 11, 2015 at 14:39
  • Do you happen to know what the command-line parameters to give are?
    – pglpm
    Commented Aug 13, 2019 at 20:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.