Linked Questions

2 votes
1 answer
909 views

how to substitute SUPER keybindings in Emacs terminal mode?

In GNU Emacs GUI, I use the Mac Command key ⌘ as super: (setq mac-command-modifier 'super) However, the ⌘ key does not send input to Terminal or iTerm2. Given this, is there a way to simulate the ...
incandescentman's user avatar
7 votes
1 answer
332 views

binding M-[ causes mouse focus to insert characters

I have bound M-[ to backward-paragraph. This causes a problem in terminal mode, whereby every time the mouse enters or leaves the frame (i.e., Emacs gains or loses focus), the characters I and O are ...
Tyler's user avatar
  • 22.4k
1 vote
0 answers
803 views

single escape to quit helm in terminal

This blog post on migrating from vim to evil-mode in emacs gives code to make a single ESC quit/cancel helm instead of 3. It worked on Emacs.app (OS X) but doesn't work from Terminal.app (both emacs ...
Alejandro Erickson's user avatar
0 votes
1 answer
524 views

global-set-key not working in terminal

I have the following line in my .emacs.d/init.el file (global-set-key [(control tab)] 'other-window) ;; remap f1 to undo (global-set-key (kbd "<f1>") 'undo) When I use the full X-window GUI ...
mikemtnbikes's user avatar
1 vote
0 answers
662 views

Ubuntu Emacs Meta Key problem related to keys

I'm using emacs 24.5.1 on ubuntu 16.04 on a Vaio x64 pc. earlier I ran the emacs tutorial and got through it completely no problem. Then I started playing with the "replace-string" command and now my ...
Vladimir Estragon's user avatar
2 votes
1 answer
491 views

'C-M--' on Emacs Terminal on OSX fails with "C-M-_ is undefined"

I'm trying to execute C-M-- from Emacs on Terminal (iTerm2) running on OSX, but I keep getting an error saying C-M-_ is undefined. Any ideas how to workaround this?
Galder Zamarreño's user avatar
0 votes
1 answer
479 views

Unable to remap key bindings involving meta under iTerm2

I'm using iTerm2, and I would like to remap some of the meta keys. In my .emacs I have (global-set-key (kbd "M-g") 'goto-line) And in my iTerm2 settings I have both "option" keys set to send +Esc. I ...
David's user avatar
  • 197
1 vote
1 answer
239 views

C+X C+; not working

I work in emacs 27.1, Ubuntu 22, Terminal. I need to comment out a block. I press Ctrl+XCtrl+;. However, the ; button is not accepted properly. It only makes an underlined e appear (only on screen, ...
Viesturs's user avatar
  • 835
1 vote
1 answer
170 views

Is it possible to bind CTRL-SHIFT-xxx and CTRL-num combination?

I'm very new to emacs and essentially came from vim where it is not possible to bind CTRL-num combination like (CTRL-1, CTRL-2, etc) which as well as CTRL-SHIFT-xxx like CTRL-# which essentially works ...
Some Name's user avatar
  • 113
1 vote
0 answers
274 views

Define key chords for windmove

I'm following info found on this link, but cannot get the desired custom key bindings to work for windmove. Basically, I put the following in my .emacs file: (global-set-key (kbd "C-M-<left>") ...
MLister's user avatar
  • 215
1 vote
2 answers
262 views

windmove doesn't recognize S-<up> and S-<down> on Macbook Terminal

GNU Emacs 27.2 in Mac OS terminal (11.4 Big Sur). Started with (windmove-default-keybindings) and found that S-<up> and S-<down> behaved just as <up> and <down>, as if the ...
PartialOrder's user avatar
0 votes
0 answers
243 views

How do I type … in the TUI?

When I call describe-key and enter … (Alt Gr + .), it says M-b runs the command backward-word […] and async-shell-command (bound to M-&) is called. I'm on Linux with Xorg, the terminal emulator is ...
tastytea's user avatar
  • 105
0 votes
1 answer
149 views

What is the keycode of C-TAB?

iTerm does not send ctrl+tab itself, so I need to configure it myself. I can't figure it what key code ctrl+tab is though.
HappyFace's user avatar
  • 830
0 votes
1 answer
108 views

Emacs' C-tab seems without effect on my server through ssh

(Emacs 27.1) On my local machine <C-tab> is linked to other-window and works well: .emacs.d/init.el: (global-set-key (kbd "<C-tab>") 'other-window) When I install Emacs on a (...
suizokukan's user avatar
0 votes
0 answers
158 views

C-M-% not works in MacOS terminal

I'm fresh to emacs and following manual to practice Query-Replace operation. But I find it not work at all. Type C-h l where it shows ESC 5 seems my OS swallow some key input or emacs parse input ...
LoranceChen's user avatar

15 30 50 per page