Linked Questions

8 votes
1 answer
7k views

What does S mean in emacs keybinding notation (org-mode) [duplicate]

Looking at the keybindings here http://orgmode.org/guide/Structure-editing.html#Structure-editing, it asks us to use M-S-<RET> to add a TODO at the same level. What does the S here mean? I ...
Andrew's user avatar
  • 561
4 votes
1 answer
2k views

Why doesn't "C-;" "C-,", or "C-." work in a terminal emulator? (OS X Terminal, Iterm2) [duplicate]

I have bound "C-;" to 'other-window in my config like so. (global-set-key (kbd "C-;") 'other-window) When I run emacs outside of a terminal, this keybinding works as I would expect. Inside Iterm2 ...
Greg Nisbet's user avatar
0 votes
1 answer
630 views

Weird keyboard behaviour by Emacs in a terminal [duplicate]

I am having problems to configure my EMACS in -nw mode using linux thorough ssh. I am trying to map Ctrl+Shift+z to redo using undo-tree-redo. I tried the following code (defalias 'redo 'undo-tree-...
Jemme's user avatar
  • 103
0 votes
1 answer
437 views

The shift is useless when I am in the iterm2 with emacs -nw [duplicate]

GNU Emacs 24.5.1 (x86_64-apple-darwin14.5.0 Org-mode version 8.2.10 (release_8.2.10 For example, when I use C-q M-Return. It shows ^[ . But when I use C-q M-S-Return. It still shows ^[ . It seems S:...
yuxuan's user avatar
  • 781
1 vote
1 answer
427 views

C-RET not recognized by Emacs in terminal [duplicate]

Attempting C-c C-RET gives me the following: C-c RET is undefined Any thoughts on what is happening here?
jujillu's user avatar
  • 11
0 votes
0 answers
521 views

Paredit slurp hotkey doesnt work [duplicate]

I'm having a real hard time getting the paredit slurp key to work. I know it is bound to C-), and by describing the paredit-slurp-forward-sexp it confirms that. When I fire up M-x describe-key and ...
Steve's user avatar
  • 65
2 votes
0 answers
396 views

C-S-Backspace not working [duplicate]

When using emacs, C-S-Backspace seems to only delete one char and not the whole line. After reading Here I see the text: "C-S-backspace (kill-whole-line) kills a whole line including its newline,...
Mark Francis's user avatar
0 votes
1 answer
204 views

Key binding in terminal emacs [duplicate]

I started to use Linux Mint. On the Terminal, I can use emacs -nw and emacs. I can't get the same key behavior about the following two configs. In particular, these settings work in emacs, but not in ...
hrkshr's user avatar
  • 143
0 votes
1 answer
128 views

C-M-... bindings in emacs -nw [duplicate]

I have an issue when I run emacs with -nw: all my C-M- bindings stop working, as C (control) doesn't register, and only the M- binding is executed. E.g: (global-set-key (kbd "C-M-.") '...
parszab's user avatar
0 votes
0 answers
47 views

C-S-n and C-= not working in emacs if running within terminal [duplicate]

I am running emacs inside tmux within iterm2 on OSX. For some reason these key bindings do not work properly C-S-n C-= C-+ C-; And some others too that are similar. All of these work when running ...
nuaavee's user avatar
  • 101
0 votes
0 answers
25 views

Meta+Shift-Return in iTerm2 on Mac not working [duplicate]

Have you met the case that Emacs in iterm2 on Mac does not recognize M-S-RET (Meta(Option)+Shift+ Return key)? I guess it's related to the modifier key conversions in terminals. M-S-RET is used in ...
jing chen's user avatar
1 vote
0 answers
22 views

Return key when Emacs running inside a terminal [duplicate]

I have re-assigned the RETURN key to exit the insert state in Evil mode. (define-key evil-insert-state-map [return] 'evil-normal-state) But this does't work with emacs -nw in terminal. Any way to ...
Arktik's user avatar
  • 972
0 votes
0 answers
22 views

C-C C-SPC not working in RHEL 6.7 GNOME 2.28.2 [duplicate]

The key C-SPC is not working in RHEL 6.7 GNOME 2.28.2. When I try C-h k and then hit C-SPC I see the following message on the mini-buffer: C-@ is undefined That is, SPC is mistaken for @.
Marcus Junius Brutus's user avatar
22 votes
3 answers
30k views

emacs on terminal does not recognise option as alt-key on mac

I am on a mac and I am running emacs 24.4.1, but I have the same problem also with 22.1.1. When I open mac on a terminal on the remote host, it does not recognise option key (alt) like the meta key. I ...
simona's user avatar
  • 403
20 votes
2 answers
3k views

How to bind C-i as different from TAB?

I want to make Control-i perform indent-region (basically since Xcode has built that muscle memory already). I realise that Control-i and tab are indistinguishable in the Ascii sense, but they are in ...
Mark's user avatar
  • 1,449

15 30 50 per page