Linked Questions

1 vote
1 answer
156 views

C+X C+; not working

I work in emacs 27.1, Ubuntu 22, Terminal. I need to comment out a block. I press Ctrl+XCtrl+;. However, the ; button is not accepted properly. It only makes an underlined e appear (only on screen, ...
Viesturs's user avatar
  • 825
0 votes
1 answer
107 views

C-M-... bindings in emacs -nw [duplicate]

I have an issue when I run emacs with -nw: all my C-M- bindings stop working, as C (control) doesn't register, and only the M- binding is executed. E.g: (global-set-key (kbd "C-M-.") '...
parszab's user avatar
0 votes
0 answers
29 views

C-c C-, not working in SSH terminal but it is bound

The function org-insert-structure-template is bound to C-c C-,. I can confirm that when search that function via M-x and seeing the shortcut behind the function name. But I use Emacs (from Debian 11) ...
buhtz's user avatar
  • 719
0 votes
1 answer
198 views

Key binding in terminal emacs [duplicate]

I started to use Linux Mint. On the Terminal, I can use emacs -nw and emacs. I can't get the same key behavior about the following two configs. In particular, these settings work in emacs, but not in ...
hrkshr's user avatar
  • 143
1 vote
2 answers
243 views

windmove doesn't recognize S-<up> and S-<down> on Macbook Terminal

GNU Emacs 27.2 in Mac OS terminal (11.4 Big Sur). Started with (windmove-default-keybindings) and found that S-<up> and S-<down> behaved just as <up> and <down>, as if the ...
PartialOrder's user avatar
0 votes
0 answers
138 views

Xmodmap modifier used for meta

I would like to set my Alt_L to trigger a meta key in emacs. I've tried using xmodmap to set Alt_L as Mod1, Mod2, Mod3. But in emacs, when i try to type Alt_L + x (expecting M-x) it only prints "...
slav3000's user avatar
0 votes
1 answer
147 views

What is the keycode of C-TAB?

iTerm does not send ctrl+tab itself, so I need to configure it myself. I can't figure it what key code ctrl+tab is though.
HappyFace's user avatar
  • 830
0 votes
0 answers
232 views

How do I type … in the TUI?

When I call describe-key and enter … (Alt Gr + .), it says M-b runs the command backward-word […] and async-shell-command (bound to M-&) is called. I'm on Linux with Xorg, the terminal emulator is ...
tastytea's user avatar
  • 105
0 votes
1 answer
105 views

Emacs' C-tab seems without effect on my server through ssh

(Emacs 27.1) On my local machine <C-tab> is linked to other-window and works well: .emacs.d/init.el: (global-set-key (kbd "<C-tab>") 'other-window) When I install Emacs on a (...
suizokukan's user avatar
0 votes
0 answers
38 views

setting C-, and C-. key bindings

I am unable to set the C-, and C-. key bindings! I tried adding the following, (global-set-key (kbd "C-,") 'forward-char) (global-set-key (kbd "C-.") 'forward-char) In various ...
Matthias's user avatar
0 votes
0 answers
25 views

Meta+Shift-Return in iTerm2 on Mac not working [duplicate]

Have you met the case that Emacs in iterm2 on Mac does not recognize M-S-RET (Meta(Option)+Shift+ Return key)? I guess it's related to the modifier key conversions in terminals. M-S-RET is used in ...
jing chen's user avatar
1 vote
1 answer
169 views

Is it possible to bind CTRL-SHIFT-xxx and CTRL-num combination?

I'm very new to emacs and essentially came from vim where it is not possible to bind CTRL-num combination like (CTRL-1, CTRL-2, etc) which as well as CTRL-SHIFT-xxx like CTRL-# which essentially works ...
Some Name's user avatar
  • 113
7 votes
1 answer
322 views

binding M-[ causes mouse focus to insert characters

I have bound M-[ to backward-paragraph. This causes a problem in terminal mode, whereby every time the mouse enters or leaves the frame (i.e., Emacs gains or loses focus), the characters I and O are ...
Tyler's user avatar
  • 22.1k
1 vote
0 answers
22 views

Return key when Emacs running inside a terminal [duplicate]

I have re-assigned the RETURN key to exit the insert state in Evil mode. (define-key evil-insert-state-map [return] 'evil-normal-state) But this does't work with emacs -nw in terminal. Any way to ...
Arktik's user avatar
  • 972
2 votes
2 answers
621 views

how to map <C-M-left>, <C-M-right> etc to the correct hex codes in iterm2

I'm looking to configure iterm2 to output the correct hexcodes that correspond to in emacs. There's a whole bunch of mappings predefined but it's very cryptic. I'm a little bit lost as to how these ...
zcaudate's user avatar
  • 637

15 30 50 per page