Linked Questions

2 votes
1 answer
905 views

how to substitute SUPER keybindings in Emacs terminal mode?

In GNU Emacs GUI, I use the Mac Command key ⌘ as super: (setq mac-command-modifier 'super) However, the ⌘ key does not send input to Terminal or iTerm2. Given this, is there a way to simulate the ...
incandescentman's user avatar
2 votes
1 answer
491 views

'C-M--' on Emacs Terminal on OSX fails with "C-M-_ is undefined"

I'm trying to execute C-M-- from Emacs on Terminal (iTerm2) running on OSX, but I keep getting an error saying C-M-_ is undefined. Any ideas how to workaround this?
Galder Zamarreño's user avatar
2 votes
1 answer
694 views

Map a key to act like a combination of modifiers

I've got a keyboard, where pressing M-C-S is uncomfortable (Meta and control are under the thumbs and Shift is on the far end of the keyboard). However, PageUp, PageDown, Home and End are in a very ...
wvxvw's user avatar
  • 11.4k
1 vote
1 answer
215 views

C+X C+; not working

I work in emacs 27.1, Ubuntu 22, Terminal. I need to comment out a block. I press Ctrl+XCtrl+;. However, the ; button is not accepted properly. It only makes an underlined e appear (only on screen, ...
Viesturs's user avatar
  • 825
1 vote
1 answer
170 views

Is it possible to bind CTRL-SHIFT-xxx and CTRL-num combination?

I'm very new to emacs and essentially came from vim where it is not possible to bind CTRL-num combination like (CTRL-1, CTRL-2, etc) which as well as CTRL-SHIFT-xxx like CTRL-# which essentially works ...
Some Name's user avatar
  • 113
1 vote
1 answer
427 views

C-RET not recognized by Emacs in terminal [duplicate]

Attempting C-c C-RET gives me the following: C-c RET is undefined Any thoughts on what is happening here?
jujillu's user avatar
  • 11
1 vote
1 answer
1k views

How to remap shift-arrow in term-mode?

Is there a way to map Shift-left or other arrow keys to custom functions in term-char-mode? I tried, but without luck: (define-key term-mode-map [s-left] 'sandric/term-switch-line-mode) Entering ...
sandric's user avatar
  • 1,271
0 votes
1 answer
128 views

C-M-... bindings in emacs -nw [duplicate]

I have an issue when I run emacs with -nw: all my C-M- bindings stop working, as C (control) doesn't register, and only the M- binding is executed. E.g: (global-set-key (kbd "C-M-.") '...
parszab's user avatar
0 votes
1 answer
204 views

Key binding in terminal emacs [duplicate]

I started to use Linux Mint. On the Terminal, I can use emacs -nw and emacs. I can't get the same key behavior about the following two configs. In particular, these settings work in emacs, but not in ...
hrkshr's user avatar
  • 143
0 votes
1 answer
149 views

What is the keycode of C-TAB?

iTerm does not send ctrl+tab itself, so I need to configure it myself. I can't figure it what key code ctrl+tab is though.
HappyFace's user avatar
  • 830
0 votes
1 answer
107 views

Emacs' C-tab seems without effect on my server through ssh

(Emacs 27.1) On my local machine <C-tab> is linked to other-window and works well: .emacs.d/init.el: (global-set-key (kbd "<C-tab>") 'other-window) When I install Emacs on a (...
suizokukan's user avatar
0 votes
1 answer
89 views

how can a command be bound to Ctrl-' or Ctrl-<NUM> in the terminal

I want to bind a command to C-', C-` and C-0 through C-9 keys. It's not working in the terminal Is there a way to do so?
zcaudate's user avatar
  • 647
0 votes
1 answer
523 views

global-set-key not working in terminal

I have the following line in my .emacs.d/init.el file (global-set-key [(control tab)] 'other-window) ;; remap f1 to undo (global-set-key (kbd "<f1>") 'undo) When I use the full X-window GUI ...
mikemtnbikes's user avatar
0 votes
1 answer
630 views

Weird keyboard behaviour by Emacs in a terminal [duplicate]

I am having problems to configure my EMACS in -nw mode using linux thorough ssh. I am trying to map Ctrl+Shift+z to redo using undo-tree-redo. I tried the following code (defalias 'redo 'undo-tree-...
Jemme's user avatar
  • 103
0 votes
1 answer
437 views

The shift is useless when I am in the iterm2 with emacs -nw [duplicate]

GNU Emacs 24.5.1 (x86_64-apple-darwin14.5.0 Org-mode version 8.2.10 (release_8.2.10 For example, when I use C-q M-Return. It shows ^[ . But when I use C-q M-S-Return. It still shows ^[ . It seems S:...
yuxuan's user avatar
  • 781

15 30 50 per page