Questions tagged [async]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
5 votes
1 answer

Almost working smoothly attempt to get terminal Emacs to copy to clipboard

I'm running this emacs GNU Emacs 25.2.2 (x86_64-pc-linux-gnu) of 2017-09-22, modified by Debian directly in a Gnome terminal by calling emacs, which is actually a link to /etc/alternatives/emacs. ...
Craig  Hicks's user avatar
26 votes
4 answers

How can I run an async process in the background without popping up a buffer?

I have defined some functions to run async background process using async-shell-command in my .emacs, but everytime I run the commands a new window (not frame) is created and the process' buffer is ...
rlazo's user avatar
  • 993
9 votes
4 answers

Async shell process buffer always clobbers window arrangement

I frequently launch external programs from emacs using M-!, such as Firefox or Evince, etc. Whenever I do, a buffer pops up full of results for the process, which clobbers whatever else I've got going ...
Steven Arntson's user avatar
5 votes
0 answers

Is there some way to continue reading from a STDIN file descriptor when data is PIPED to Emacs on Command-line?

Historical Perspective On Unix like operating systems, it is common practice to redirect IO between shell commands using pipes. For example, the command below would insert all the lines that didn't ...
Melioratus's user avatar
  • 4,564
13 votes
1 answer

Asynchronously wait for output from a comint process

First of all, a disclaimer. I have researched this many times, and I am pretty sure that I have already found the answer one way or another, but I just don't understand it. My problem is the ...
T. Verron's user avatar
  • 4,263
5 votes
1 answer

Asynchronous version of shell-command-on-region?

I have a problem which is very similar to this one. I have some text that I'd like to listen to with macOS's say utility. Unfortunately, Emacs locks up when I use shell-command-on-region because it is ...
GDP2's user avatar
  • 1,340
4 votes
2 answers

start-process output processed too slowly

When start a command asynchronously, using (start-process ...), the output is added to the buffer 3-5 times more slowly than if I had used (async-shell-command ...). I don't have any output filters, I ...
erjoalgo's user avatar
  • 863
2 votes
1 answer

async org-agenda

I have a lot of org files in emacs 27.1 so when I do an agenda listing for the week it takes about 20seconds. Is there a nice way to do this in the background? I've put together the following function ...
map7's user avatar
  • 513
2 votes
0 answers

How to avoid losing focus after starting an asynchronous process?

The lisp function start-process is meant to start an asynchronous subprocess, namely a process running independently of Emacs itself. I have noticed that, under my GNOME desktop environment, when my ...
Ruy's user avatar
  • 839
1 vote
1 answer

How to start a persistent asynchronous process trough emacs?

I am writing a lisp program to be run as a batch file through emacs. The program calls an external application which is supposed to stay running after the call to emacs finishes. The two basic ways ...
Ruy's user avatar
  • 839