The Stack Overflow podcast is back! Listen to an interview with our new CEO.

Questions tagged [auto-fill-mode]

The tag has no usage guidance.

7 questions with no upvoted or accepted answers
Filter by
Sorted by
Tagged with
3
votes
0answers
61 views

Enabling auto-fill-mode only when document already filled

I have turn-on-auto-fill as part of my text-mode-hook. This works great for new documents, but when I open a buffer that is not filled with hard breaks I rarely want to start doing so to a single ...
1
vote
0answers
17 views

How to avoid annoying `auto-fill` behaviour in `c-mode` comment?

Recently I write quite a lot comments for c/c++ files. I use auto-fill-mode for comment auto format. But I found a quite annoying problem: whenever I input SPC at the end of a comment line, the cursor ...
1
vote
0answers
60 views

Why does Emacs fill-paragraph corrupt this paragraph layout?

To reproduce what appears to be a bug that I'm encountering, create a new buffer with Emacs 26.1 (Fundamental mode is fine), and paste the following text in: Without message passing to worry about, ...
1
vote
0answers
64 views

auto-fill-mode fails in comment with empty second line

Consider the following comments: ;; This is the first line of a comment. ;; ;; This is the second line, which begins a paragraph. If I have ;;auto-fill-mode enabled, I lose the leading space! ;; ...
1
vote
0answers
27 views

Autofill insert a special string before returning

I use autofill in org mode to return automatically after 80 characters, the thing is that when exporting to html newlines aren't automatically added. So I would like to know if it is possible to tell ...
1
vote
0answers
44 views

auto-fill and auto-hscroll interferes, causing unnecessary horizontal scrolling

When both auto-fill-mode and auto-hscroll-mode are enabled, I often end up with a window that is horizontally scrolled, even though the entire content of the window should fit into an unscrolled ...
0
votes
0answers
28 views

Emacs adding comment char when using auto-fill-wrap

I'm pretty new to emacs, so this might be a stupid question but I have auto word wrap enabled like so: (setq-default auto-fill-function 'do-auto-fill) But when I try to use it in C files, It ...