Skip to main content
Share Your Experience: Take the 2024 Developer Survey

Questions tagged [characters]

A “character” in Emacs Lisp is nothing more than an integer. In other words, characters are represented by their character codes. A "character" is a different type from a "string".

Filter by
Sorted by
Tagged with
7 votes
2 answers
978 views

Idiomatic way of extending keymap for inserting unicode symbols?

I often find myself needing to insert Unicode characters that have no default binding in iso-transl-ctl-x-8-map, i.e., characters that can't be inserted using C-x 8 followed by one or more letters/...
itsjeyd's user avatar
  • 14.7k
5 votes
1 answer
3k views

Test char at point

I want to test if char at point is, let's say, "{" I found: (string= "{" (buffer-substring-no-properties (point) (+ 1 (point)))) and: (string-match-p "{" (what-cursor-...
Gabriele's user avatar
  • 1,618
5 votes
2 answers
781 views

Zero width space shows as underscore

Typing a zero-width space in TERMINAL emacs shows an underscore-ish character. How to make it showing nothing?
FunkyBaby's user avatar
  • 807
4 votes
2 answers
2k views

Non-greedy regex not working

I can't seem to get the non-greedy regex to work. Sample String: ABCD,E《F》、《GH》、《XYIJ》、《KL》、《MN》。 Regex Code: 《.+?IJ》 Search Result: Because .+? is a non-greedy input, I was expecting the ...
Sati's user avatar
  • 815
2 votes
1 answer
107 views

How to replace a digit by a letter?

I want to replace some digits by letters such that 1 ---> a 2 ---> b ... In emacs I have tried the following replacement: M-x query-replace-regexp RET \([0-9]+\) RET \,(string (+ ?a \#1)) RET ...
Onner Irotsab's user avatar
1 vote
1 answer
249 views

How to remove characters causing encoding error

When I visit any file under a certain file tree, emacs spits out this error: These default coding systems were tried to encode text in the buffer ‘ *temp file*’: (utf-8 (7862 . 4194279) (14646 . ...
Luctins's user avatar
  • 120
1 vote
0 answers
136 views

how to turn off special character?

I am pretty new to emacs. does anyone how to turn off special character, such as 渘 ? I tried to search online but no luck. emacs 28
eric123's user avatar
  • 11
0 votes
1 answer
19 views

correct elisp code to create frameset registers?

If I evaluate this: (frameset-to-register "r") then r is created as an empty register (try to jump to it afterwards!), whereas I'd like it to contain the frameset configuration just like C-x ...
user43824's user avatar