Questions tagged [control-characters]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
19 votes
2 answers

How to bind C-i as different from TAB?

I want to make Control-i perform indent-region (basically since Xcode has built that muscle memory already). I realise that Control-i and tab are indistinguishable in the Ascii sense, but they are in ...
Mark's user avatar
  • 1,409
1 vote
1 answer

How to bind C-S-m and avoid S-RET?

I am trying to rebind kmacro-start-macro and kmacro-end-macro to C-m and C-S-m. But I am having some issues because of C-m being equivalent to RET, the ASCII control character "carriage return&...
nephewtom's user avatar
  • 2,229
1 vote
2 answers

When reloading an org mode file, why do I get a whole bunch of `^M` chars in my file?

I'm just learning emacs and I'm using spacemacs configuration. I created a .org file and everything looks normal when I save it, but when I reload it I get a whole bunch of ^M chars at the end of each ...
Patrick Ryan's user avatar
1 vote
1 answer

clean weird characters from org source shell

When I run a shell command in Org I sometimes get back weird control characters: #+begin_src sh :results output :session test guix pull #+end_src #+RESULTS: : : Updating channel 'guix' from Git ...
Lorem Ipsum's user avatar
  • 4,357
1 vote
1 answer

What ASCII character is C-q C-E?

I did a spurious replacement across many files that shows in Emacs as '^E', equivalently the result of C-q C-E. What ASCII character does that correspond to, so I can undo the replacement?
user avatar
0 votes
1 answer

What are these characters?

I have been on the agenda of actually applying the formatting done by various programs within various types of Emacs major modes, e. g., the compilation major mode. I found this and added this to my ...
scribe's user avatar
  • 960
0 votes
1 answer

How can I prevent Ctrl+n to write into buffer?

I am using my-run-latex () function (explained here: How can I run additonal linux commands after compiling a latex file) after each save, which I do very often. I bound it to: (add-hook 'LaTeX-mode-...
alper's user avatar
  • 1,238
0 votes
1 answer

how to stop emacsclient on terminal insert `[I]` when I open a file?

I'm using emacs on MacOS (v11.4 Big Sur) installed from homebrew-emacs-plus and, every time I want to open a file for a quick edit on the terminal (on iTerm2) using emacsclient, a character gets ...
Hugo's user avatar
  • 111