Questions tagged [debugging]

Debugging is a methodical process of finding and reducing the number of bugs, or defects, in a computer program.

Filter by
Sorted by
Tagged with
10 votes
1 answer

How to debug errors in sentinels and during font-lock

When an error occurs inside a process sentinel or during font-locking, then Emacs doesn't show a backtrace even though debug-on-error was previously enabled. I understand why these errors are caught, ...
tarsius's user avatar
  • 25.1k
4 votes
1 answer

Why did I get an error message: wrong-type-argument stringp user-init-file

I have (set-register ?E '(file . user-init-file)), so that I can easily jump to my config file. Previously I used a string to specify the path to my init file, but I figured I'd tidy it up a bit. ...
Squidly's user avatar
  • 1,499
0 votes
1 answer

Scrolling seems to add an unwanted chunk into my kill ring

Anybody know why this may be occurring? Here is an outline of how I recreate the issue... I copy or kill something to my kill ring. I scroll up or down with the mouse. I then yank and get an ...
Alistair Chisholm's user avatar
4 votes
1 answer

Debugging server related warning message

I've been seeing this issue for some time now, but I don't know how to debug it. I start up a emacs instance, using say emacs foo.tex & Then I run C-c C-c to compile. A new window pops open, ...
Faheem Mitha's user avatar
3 votes
0 answers

Why doesn't auto-complete work in ruby-mode?

I have spent several days trying to debug auto-complete, it is working properly in Elisp mode, but when I go in Ruby mode it stops working. auto-complete-mode runs successfully, but the menu of ...
vyusfire's user avatar
2 votes
1 answer

How do I make a bug report or feature request against GNU Emacs? [duplicate]

I found this list at the emacswiki: FFI (foreign function interface). Would be great to have this in GNU. Enhanced Numerics. We sorely need this too. Apparently much better multimedia support (Of ...
Nathan Basanese's user avatar
2 votes
1 answer

Make comint-mode behave more like term-mode

I am constantly getting frustrated with the GDB comint-mode buffer when using GUD. Somehow my cursor always ends up straying from the bottom of the buffer, and then my input is not interpreted how I ...
nispio's user avatar
  • 8,143
9 votes
4 answers

How to debug startup problem, if `--debug-init' has no effect

When I launch Emacs24 (in an Ubuntu machine) I get an error message in the init procedure. Warning (initialization): An error occurred while loading `/home/nivaca/.emacs': But when I launch it with ...
NVaughan's user avatar
  • 1,461
2 votes
1 answer

Show breakpoints when debugging Matlab

I am using matlab-emacs to debug a matlab script from inside of emacs with GUD. Everything seems to be working as expected except that I don't see any breakpoint indicators in the fringe. This is ...
nispio's user avatar
  • 8,143
62 votes
4 answers

Debugging a frozen Emacs

I am using mew for my e-mail. I need to use TLS with my email provider for SMTP. However, when I try to invoke that, Emacs freezes. I would like to take this opportunity to learn more about Emacs ...
Svante's user avatar
  • 721
56 votes
9 answers

Using Emacs as a full-featured C/C++ IDE

I have been trying off and on for over a year now to use Emacs as a C/C++ IDE. I have only been marginally successful thus far, but have run into a few brick walls along the way. Currently I am ...
nispio's user avatar
  • 8,143
7 votes
3 answers

How to debug Helm

I am having some trouble with helm, so I have set debug-on-error in an effort to locate the problem. Now whenever the problem occurs, the *Backtrace* buffer appears as expected, but I am still in one ...
nispio's user avatar
  • 8,143
2 votes
2 answers

"Symbol's value as a variable is void: defun" when reloading .emacs?

I am always editing my .emacs file, and I was just wondering if I could reload it without restarting Emacs? Note: I have tried M-x load-file and choosing the .emacs file, but I get this error ...
programking's user avatar
  • 6,984
9 votes
2 answers

Better debugging of crashing Emacs?

Although Emacs ( runs fine if launched from the Finder, if the terminal version is launched: /Applications/ -nw Emacs crashes with: Fatal error 11: ...
gsl's user avatar
  • 1,722

7 8 9 10