Stack Exchange Network

Stack Exchange network consists of 175 Q&A communities including Stack Overflow, the largest, most trusted online community for developers to learn, share their knowledge, and build their careers.

Visit Stack Exchange

Questions tagged [emacs-nox]

The tag has no usage guidance.

1
vote
0answers
40 views

Show Git gutter after linenumbers

I am using emacs-nox and as some of you know there are always some problems if you want to display you line numbers while also using git-gutter. (Stuff like some extra margin jumping numbers etc.) ...
0
votes
0answers
40 views

How to remove ^[(B in Emacs-nox shell buffer?

Emacs-nox shell (M-x shell) generate on output of yum search and other type of command a ^[(B ================================================ N/S matched: linker =====================================...
1
vote
1answer
175 views

Keybinds on xterm and emacs-nox

I've looked on google, stack exchange, GNU emacs manual, xterm manual, etc. and still haven't found an answer that satisfies my problem(s). Problem: Using Systems: Ubuntu 16.04, xterm, emacs-nox I ...
0
votes
0answers
56 views

Terminal cursor movement stutters when mouse cursor is hovered over terminal

I using emacs-nox with Ubuntu 16.04LTS. The problem I'm facing is that whenever my mouse cursor is hovering over the terminal window, I experience very stuttery cursor movement. As you can see in ...
1
vote
1answer
182 views

Themes in emacs-nox displaying bottom part of frame black instead of background color

Edit: I tried many themes and it was an issue for all of them so this is not a Zenburn specific issue. Edit: Docker is not part of the issue as there is the same behavior when this is done using just ...
1
vote
1answer
722 views

Error (use-package): Failed to install magit: Package `magit-' is unavailable

I am starting to build up a .emacs file to be used as a development environment within Docker containers. I get this error when starting emacs-nox in a Docker container. Error (use-package): Failed ...
3
votes
2answers
2k views

error: Package `use-package-' is unavailable

I am starting to build up a .emacs file to be used as a development environment within Docker containers. I get this error when starting emacs-nox in a Docker container. Warning (initialization): An ...
0
votes
1answer
129 views

All arrow keys in dired+ buffer mapped to M-O

For some reason when I press Up, Down, Left or Right keys on keyboard in dired+ mode, emacs reads them all as M-O key, which I found out by describe-key command in dired+ buffer. I have no config ...