Skip to main content
Share Your Experience: Take the 2024 Developer Survey

Questions tagged [emacs26]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
0 votes
1 answer
34 views

Trouble installing emacs 26.3 Red Hat

Followed these steps: Downloaded emacs-26.3.tar.gz, drop it in a subdir of my home dir cd to there tar -xvf emacs-26.1.tar.xz Seems happy a bunch of files appear cd emacs-26.3 ./configure --prefix=/...
Mikef's user avatar
  • 175
1 vote
2 answers
174 views

Symbol's function definition is void: python-font-lock-assignment-matcher

My emacs won't start properly any more. The basic, unmodified interface is opened with the following error: Warning (initialization): An error occurred while loading ‘/home/qohelet/.emacs’: Symbol's ...
Qohelet's user avatar
  • 185
3 votes
1 answer
29 views

can't make vm run in emacs > 25;

My life depends on the vm email reader in emacs, and I'm currently using vm 8.2.0b under emacs 25.2.2. When trying to upgrade emacs, I run into problems. In emacs 26.3, I get the message "Symbol'...
user36010's user avatar
0 votes
0 answers
55 views

Emacs-26 Big Sur (Intel) 11.2 - make fails error 137 macroexp.elc

Xcode: 12.4.0.0.1.1610135815 CommandLineTools: 12.4.0.0.1.1610135815 I've exported CC=clang, but I can't get the emacs-26 branch to compile on my Big Sur Intel machine. See gist here .autogen.sh and ...
o__b's user avatar
  • 23
1 vote
0 answers
268 views

Incompatible Packages w/ 26.3 and MELPA

I know I must be missing something simple, but I've recently upgraded my Linux OS to Mate 20.04. As a result, my version of emacs is Emacs 26.3. I'm now running into incompatibility issues with MELPA ...
mikemtnbikes's user avatar
1 vote
3 answers
437 views

Org mode headlines without bold font inside emacs

Is it possible to set org-mode to show the headlines inside emacs without bold font? My emacs: * Headline 1 <-- This is bolded a paragraph <-- This is not bolded ** Headline 2 <--...
Lucas Moreira's user avatar
0 votes
1 answer
302 views

Is the GPG signature of Emacs 26.3 still valid?

I was trying to install Emacs on my Windows 8.1 machine (thus WSL is not an option). I downloaded the file from a mirror (emacs-26.3-x86_64.zip), along with his signature (emacs-26.3-x86_64.zip.sig). ...
Alessandro Bertulli's user avatar
0 votes
0 answers
1k views

Make tabs behavior like in other IDEs

How can I force Emacs to use tab button and TAB character in "normal stupid way"[1], like in nano or VScode or JetBrain's IDEs. All I can find is smart-tabs package and indent-tabs-mode, but ...
superpupervlad's user avatar
1 vote
1 answer
2k views

Unable to install emacs-26.3 after removing emacs-28 (stuck without an editor!)

I've installed emacs28 from snapshot (emacs-snapshot-common) without realizing it's the latest bleeding edge and not the latests stable version. I tried installing 26.3 from Kevin Kelly's repo, as ...
Jonathan Sahar's user avatar
1 vote
2 answers
193 views

Emacs 24.3 and 26.3 scrollbars refuses to move up if not moved up immediately, on various OS's and X-servers

The problem manifests on: Emacs 26.3 on Fedora Release 31, using Xming on Windows 7 as X server, whether in -Q mode or not Emacs 24.3 on RHEL7, using MobaXterm 12.2 4204, whether in -Q mode or not ...
Swiss Frank's user avatar
1 vote
1 answer
45 views

How do I prevent the deletion of ~/.emacs.d/auto-save-list/.saves-PID-HOSTNAME~ files?

I recently upgraded to Emacs 26.3 from a much older version of Emacs (22.x). One of the many changes I've noticed with Emacs 26.3 is that the ~/.emacs.d/auto-save-list/.saves-PID-HOSTNAME~ files are ...
Ed Sabol's user avatar
  • 141
2 votes
2 answers
2k views

TRAMP on Emacs 26 doesn't work (macOS)

I've just installed Emacs 26.3 on my macOS 10.10 (Yosemite) using the binary at Emacs for OSX Everything so far works fine icluding new package installations and different themes. However, when I ...
Terry's user avatar
  • 370
0 votes
0 answers
166 views

Unable to install emacs 26.3

I am trying to install emacs 26.3. In installed sudo apt install autoconf make gcc texinfo libgtk-3-dev libxpm-dev libjpeg-dev libgif-dev libtiff5-dev libgnutls-dev libncurses5-dev It cant find ...
velcro12's user avatar
2 votes
1 answer
319 views

sudden let-alist feature failure

This morning, I wake up and restart my Emacs.app (26.3 GNU Emacs but the emacsformacosx.com version, from brew cask) and get stuck at this: Eager macro-expansion failure: (error "Loading file /Users/...
Erik Kaplun's user avatar
1 vote
1 answer
415 views

Insert date using a calendar - where other language rather than english is desired

I am interested in inserting custom dates using the calendar, I found Insert date using a calendar which turned out to be quite useful. Org calendar : change date language? seems to have no effect (I ...
Cesc's user avatar
  • 289
1 vote
1 answer
261 views

Copy or paste between terminal emacs 26 and Mac apps

I am using terminal emacs a lot, and the method from Copy text from Emacs to OS X clipboard works for a long time. But after upgrading to Emacs 26, if I kill a string like "你好" from emacs, and paste ...
silencej's user avatar
  • 111
2 votes
1 answer
195 views

"void-variable" error when adding advice to `kill-ring-save`

I am trying to add an advice to kill-ring-save and kill-region, so that when I call them with no active regions, instead of throwing an error, the line the point is currently on would be marked ...
nalzok's user avatar
  • 675
0 votes
1 answer
134 views

Emacs26 on Windows 7, Why is Setting Mark shortcut toggling language instead?

I just installed Emacs26 on my Windows 7 64-bit computer and whenever I try setting a mark ctrl + <space>, it toggles the Windows language settings instead. M-x set-mark-command works as ...
bork's user avatar
  • 103
1 vote
0 answers
257 views

Is org-capture broken?

I use emacs-26.1 org-version 9.1.14. My templates (list) is showing up but when I choose a template I get: org-capture: Capture abort: (void-function org-eldoc-load) I can't find org-eldoc.el in my ...
Johan Sandén's user avatar
2 votes
0 answers
78 views

Strange comment indentation results

I am working with a simple major mode. The format has one single line comment delimiter, i.e., %. However, I get strange results when running fill-paragraph on a comment. Specifically, the result I ...
chaosape's user avatar
  • 121
4 votes
3 answers
1k views

Make Org Table with #+NAME label collapsible

I have an org table with has a NAME label like: #+NAME: TBL | Foo | Bar | In the past I have always been able to expand and collapse the whole table by cycling using TAB on the #+NAME line. However ...
Phil's user avatar
  • 535
3 votes
1 answer
177 views

Why doesn't the same Windows font look the same when migrating to emacs 26.1?

I'm trying to migrate from emacs 24.5 to emacs 26.1. I installed 26.1 and running both with the same config files. I took several tries and fixing small things in the config, for emacs 26.1 to start ...
Tom's user avatar
  • 1,260
15 votes
1 answer
4k views

After I updated Emacs 25.1 to 26.1 org-mode does not work any more

I am anything but an Emacs expert but I use Emacs org-mode quite frequently. I configured Emacs to regognize .org files. After I updated to version 26.1 Emacs does not only recognize .org files any ...
Martin Petersen's user avatar
3 votes
1 answer
598 views

M-S-up/down in org-mode suddenly does not 'move' whole items anymore

Consider a .org file containing * Item 1 - Item 1.1 - Item 1.2 * Item 2 - Item 2.1 - Item 2.2 with the point being at Item 2. With GNU Emacs 25.2.1 (x86_64-apple-darwin13.4.0) of 2017-04-21 ...
Marius Hofert's user avatar
5 votes
2 answers
149 views

(ucs-names) in Emacs 26 is not working for "EURO SIGN"

I have in my .emacs: (when (>= emacs-major-version 23) (define-key global-map "\C-x8g" (lambda nil (interactive) (ucs-insert `,(cdr (assoc-string "HRYVNIA SIGN" (ucs-names) t))))) (define-key ...
gavenkoa's user avatar
  • 3,452
2 votes
1 answer
109 views

Since upgrading to emacs 26.1 C-SPC behaviour changed and I have to press it twice to set-mark

Since upgrading to Emacs 26.1 C-SPC behaviour changed and I have to press it twice (most of the time) to set mark, which disrupts my flow and is hard on my thumb joint (don't ask). I'd like to ...
Alien Life Form's user avatar
1 vote
1 answer
673 views

Emacs 26 build on RHEL6 has blank window frame

I just built Emacs 26.1 (stable) on Centos 6 (RHEL 6.9). When I fire up the executable with src/emacs -Q over X11 it shows an empty window with no minibuffer: I built Emacs without gnutls, but that ...
halloleo's user avatar
  • 1,345
13 votes
6 answers
10k views

aspell with emacs 26.1 on ms windows

After updating emacs to version 26.1 on a windows machine, I get the following error message from flyspell: Error enabling Flyspell mode: (c:/Program Files (x86)/Aspell/bin/aspell.exe release 0.60 or ...
B_old's user avatar
  • 717
6 votes
1 answer
2k views

Emacs 26.1 RC1 display issues over SSH/X11 with xming/vcxsrv

I can compile Emacs 26.1 RC1 ok, and use it locally on the host fine. However, when attempting to ssh -X to host via PuTTY 0.70 and launch the Emacs gui, emacs is not displaying correctly. See ...
bscipio's user avatar
  • 181
22 votes
7 answers
29k views

how install emacs 26 (or whatever latest ver) on mac

Someone (in another SE answer) mentioned a feature thats only available in 26, so I guess now I gotta upgrade. How do you install emacs 26 on macOS Sierra? What I tried: Googled how install emacs ...
american-ninja-warrior's user avatar
2 votes
0 answers
3k views

Show both relative and absolute line numbers in Emacs 26

One of the new features in Emacs 26 is display-line-numbers-mode: Emacs now supports optional display of line numbers in the buffer. This is similar to what linum-mode provides, but much faster and ...
izkon's user avatar
  • 1,878