Questions tagged [emacs28]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
3 votes
2 answers

Seq-Keep is void when installing magit through use-package

I've been attempting to use magit but it keeps throwing an error that seq-keep is void. I started up emacs only installing use-package and magit and the issue persists. However, when I installed magit ...
NepNep-NepNep's user avatar
2 votes
0 answers

lsp-mode's magic to prevent C-x 1 from working?

When I start emacs all functionality of frames works fine. I can split frame by two via "C-x 3", switch to it "C-x o", and then close other (left) frame via "C-x 1". But ...
user1244932's user avatar
1 vote
1 answer

How to overwrite protected files in dired

I was trying to copy my some of my config folders to another system which was mounted with root privileges using dired. I opened both surrounding folders using /sudo::/... and tried to copy my files ...
Alexander Praehauser's user avatar
0 votes
1 answer

Color emoji arrows in emacs

I have attempted to setup emacs 28.2 to display color emojis using the Noto Color Emoji font. According to a "Font Manager" program (provided by font-manager Debian package), the following ...
s-t-s's user avatar
  • 1
4 votes
1 answer

Is package-initialize needed in the init file in Emacs 28.x and higher?

I have this line in the early-init.el file: (setq package-enable-at-startup nil) and these lines in the init.el file: (require 'package) (add-to-list 'package-archives '("melpa" . "...
Zoli's user avatar
  • 421
1 vote
0 answers

Display AVIF images?

I enabled image-use-external-converter, and I added avif to image-file-name-extensions and AVIF to imagemagick-enabled-types. However, that doesn't do the trick. I would like AVIF files to render in a ...
feklee's user avatar
  • 1,049
0 votes
0 answers

Repeat mode doesn't repeat, how to debug?

repeat-mode is completely failing to operate as advertised. I get the message saying it's enabled, and thereafter Emacs carries on exactly as if it has not been enabled, with supposed command-...
Phil Hudson's user avatar
  • 1,701
2 votes
2 answers

Emacs 28: How to use `RET` without exiting a recursive edit within a keyboard macro?

Now that I switched to using GNU Emacs 28.1 (build 1, x86_64-apple-darwin18.7.0, NS appkit-1671.60 Version 10.14.6 (Build 18G95)) of 2022-05-11 I can no longer end my use of my keyboard macro that ...
Alan Wehmann's user avatar
3 votes
1 answer

Org mode babel hangs with python C-c C-c

When I C-c C-c in a Python code block in Org mode: #+BEGIN_SRC python :results value :session a = 4 a + 13 #+END_SRC It hangs with a message: Warning (python): Your ‘python-shell-interpreter’ ...
Jay Lee's user avatar
  • 143
0 votes
1 answer

command-execute error with straight.el

I have just tried to setup magit using straight.el in my init file as follows: (use-package magit :straight t :bind ("C-x g" . magit-status) :commands (magit-status ...
user4687531's user avatar
3 votes
1 answer

Turn off fringe character for org-capture

I updated to Emacs 28 recently and org-capture now puts a small character in the left fringe for captured items. I know that I can set fringe-mode to no-fringe to not see any fringe, but that's not ...
jrasband's user avatar
1 vote
0 answers

Getting an error when running the Emacs 28.1 binary that I built from source (--with-native-compilation)

When building Emacs 27.2 from source, I use the following config: ./ ./configure --prefix=/home/user/emacs --bindir=/home/user/bin \ --with-json --with-gif --with-jpeg --with-png --with-...
cinnaroll45's user avatar
2 votes
2 answers

How to prevent Emacs 28 from native-compiling everything?

Not sure what's going on, but suddenly Emacs just started byte-compiling native-compiling everything, all Elisp files. No idea how to get it to stop or what caused this. It's doing all the packages ...
tbny's user avatar
  • 51
0 votes
1 answer

Problem loading packages with Emacs 28

I have installed Emacs 28 with snap from My init.el is configured using use-package. However, I get the following errors when I try to install and load custom ...
Swarnendu Biswas's user avatar