Questions tagged [gccemacs]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
0 votes
0 answers
18 views

Error Invoking GCC Driver on Windows

I recently installed gcc compiler MinGW on Windows 11, and haven't been able to run Emacs with my config files. I tried to disable logging, but they show up again on starting Emacs. Warning (...
  • 211
0 votes
0 answers
19 views

emacs-pgtk for WSL2 - identification and clipboard issues

I installed emacs-pgtk version 29.0.50 (build 2, x86_64-pc-linux-gnu, GTK+ Version 3.24.33, cairo version 1.16.0) from the git repo following these instructions with ./configure --with-native-...
  • 1,004
0 votes
0 answers
115 views

emacs Async-native-compile consumes high memory on server startup

I am using https://www.emacswiki.org/emacs/GccEmacs : GccEmacs refers to the --with-native-compilation configuration option when building Emacs, which adds support for compiling EmacsLisp to native ...
  • 1,152
0 votes
1 answer
132 views

Is it possible to install GccEmacs for Emacs 27.2

For installing GccEmacs, I have followed: https://www.emacswiki.org/emacs/GccEmacs git clone git://git.savannah.gnu.org/emacs.git cd emacs ./autogen.sh ./configure --with-native-compilation make -j$(...
  • 1,152
1 vote
0 answers
576 views

Compiling gccemacs (Emacs 28) from source. To bootstrap or not to bootstrap?

With the following build script on Big Sur + homebrew, I get horribly long compile times when using make bootstrap as opposed to simply make on gccemacs. I've read the Makefile in the src directory - ...
  • 13
11 votes
4 answers
4k views

Is there a gccemacs (native-comp) build for MS-Windows?

I use the official binaries (28.0.50 prerelease) for MS Windows. I am using gccemacs on my home Linux machines, and feel like native-comp on Windows would be really useful for me at work. However, I ...
  • 185
18 votes
5 answers
11k views

Compile emacs from feature/native-comp (gccemacs) branch on Ubuntu

I want to compile the gccemacs branch of Emacs. When I run ./configure, the configure script errors with: cd emacs git checkout feature/native-comp ./autogen.sh ./configure --with-nativecomp ...
  • 1,302