Skip to main content
Share Your Experience: Take the 2024 Developer Survey

Questions tagged [gnutls]

GnuTLS is a secure communications library implementing the SSL, TLS, and DTLS protocols and technologies around them. It provides a simple C language application programming interface (API) to access the secure communications protocols as well as APIs to parse and write X.509, PKCS #12, OpenPGP and other required structures. It is aimed to be portable and efficient with focus on security and interoperability.

10 questions with no upvoted or accepted answers
Filter by
Sorted by
Tagged with
4 votes
0 answers
755 views

Opening TLS Connection fails

I installed powerthesaurus package from MELPA. This package finds out synnyms of selected words from powerthesaurus.org. I installed all the dependencies (dom - to be specific which did not get ...
Prasanna's user avatar
  • 1,550
2 votes
0 answers
348 views

Cannot upgrade packages when adding melpa to the package-archives

I have problems upgrading packages coming from melpa: When executing list-package with "https://melpa.org/packages/" in the package-archives I get the following in the *Messages* buffer: ...
halloleo's user avatar
  • 1,345
1 vote
1 answer
767 views

Failed to download ‘melpa-stable’ archive. GnuTLS : Contacting host: 443

I am trying to install packages/modes from melpa on my emacs27.1, but I am unable to do so. If I run M-x package-refresh-contents , I get the following error : Importing package-keyring.gpg...done ...
Vignesh S's user avatar
1 vote
0 answers
303 views

url-http unable to connect to api - gnutls error

I am using restclient-mode and trying to POST JSON to an API I'm writing. Making curl requests works fine but I'm getting these errors from restclient.el: My restclient-mode request looks like this: ...
bitops's user avatar
  • 353
0 votes
1 answer
83 views

Opening TLS connection with ‘gnutls-cli --x509cafile /private/etc/ssl/cert.pem -p 443 stable.melpa.org’...failed

I am making a new Emacs config an in it, I have the following lines (with-eval-after-load 'tls (push "/private/etc/ssl/cert.pem" gnutls-trustfiles) (setf gnutls-verify-error nil) (setf ...
MadPhysicist's user avatar
0 votes
0 answers
93 views

gnutls-available-p is void despite emacs being built with gnutls

I am attempting to secure my emacs 28.1 following the well-known guide here. After running into a (seemingly common) error with the bad certificate check I was lead to this emacs stackexchange post. ...
CL40's user avatar
  • 133
0 votes
0 answers
78 views

Understanding certificate security warning

I'm encountering the below warning about a change in the fingerprint for a server I regularly connect to: Certificate information Issued by: R3 Issued to: CN=sms.erjoalgo.com ...
erjoalgo's user avatar
  • 873
0 votes
2 answers
1k views

Elpa + Melpa Certificate information issue at startup

I hadn't used Emacs for a few weeks and when I started it up I discovered issues with certificate information for elpa, melpa and orgmode. When I launch Emacs I get the following message: The TLS ...
twicetwice's user avatar
0 votes
1 answer
54 views

Wordpress blogging with org2blog, "Error during request: 400"

I used to use org2blog to post my wordpress posts. However, a few months ago, it suddenly stopped to work: when I tried to log in with org2blog/wp-login I had an "Error during request: 400" ...
Picaud Vincent's user avatar
0 votes
0 answers
841 views

Sending email with gnutls stopped working

I've been using the following setup Gnus SMTP ;;; SMTP (defun email-settings () (interactive) (setq message-send-mail-function 'smtpmail-send-it starttls-gnutls-program "gnutls-cli" ...
The Dude's user avatar
  • 473