Stack Exchange Network

Stack Exchange network consists of 174 Q&A communities including Stack Overflow, the largest, most trusted online community for developers to learn, share their knowledge, and build their careers.

Visit Stack Exchange
Join us in building a kind, collaborative learning community via our updated Code of Conduct.

The tag has no usage guidance.

0
votes
1answer
26 views

ESS install fails on Ubuntu 18.04

I had previously installed and used Emacs 25.2.2 and ESS 17.11 on Ubuntu 18.04 (Bionic Beaver). While attempting to update to the latest version of ESS, the ESS install script appears to have failed (...
0
votes
2answers
43 views

ESS not installable (Ubuntu 18.04)

The day before yesterday, I have experienced my Ubuntu package ess (Version: 17.11-3bionic0) no more configuring properly during apt-get update. I then tried apt-get install -d ess and: dpkg -i /var/...
0
votes
2answers
27 views

Installing with package-install-file

I am trying to install the gauche-mode. Running the M-x package-install-file and giving the /path/to/gacuhe-mode/ directory gives the Read error: is a directory, /path/to/gacuhe-mode/. How can i ...
0
votes
0answers
53 views

Spacemacs install package : error package lacks a version

I would like to use the org-books package in spacemacs. As suggested by spacemacs' documentation I edited my .spacemacs file as follows: dotspacemacs-additional-packages '((org-books :location (...
0
votes
1answer
47 views

How to automatically install Auctex if certain package is unable to be activated on startup?

every time I git clone my configuration of Emacs into a new machine and start Emacs, there will be error message in Emacs: error: Unable to activate package 'company-auctex'. Required package 'auctex-...
0
votes
1answer
38 views

Why is the Magit M Remote pop-up different than what is shown in the Magit manual?

The Magit manual, 7.1.1 The Remote Popup, describes the following three commands, but they do not appear in my 'M' popup: M C (magit-remote-config-popup) M p (magit-remote-prune) M P (magit-...
0
votes
0answers
34 views

Combine use-package and list-packages

Is it possible to automatically add use-package statement into .emacs file after installation through list-packages? I think it should be done through hooks, but maybe already exist solution from ...
1
vote
1answer
69 views

Error with org-fstree: Symbol's function definition is void: reduce

I want to use the package org-fstree (MELPA Link). But in a file when I press C-c C-c at #+BEGIN_FSTREE: ~/ I get the following error: Symbol's function definition is void: reduce I am not sure ...
2
votes
0answers
36 views

Error when I try to re-install package after deleting it

I used package-install to install the pamparam package. It worked. But in playing with it, I got it into a weird state and decided to uninstall and re-install. I uninstalled by deleting its dir in ....
7
votes
2answers
3k views

how install emacs 26 (or whatever latest ver) on mac

Someone (in another SE answer) mentioned a feature thats only available in 26, so I guess now I gotta upgrade. How do you install emacs 26 on macOS Sierra? What I tried: Googled how install emacs ...
1
vote
1answer
291 views

How to build Emacs for an embedded ARM Linux system

I am trying to build Emacs for an embedded ARM Linux system. Unfortunately, it is proving to be more difficult than I anticipated. I have the device mounted at /mnt/my_device. Now I am not sure ...
0
votes
0answers
62 views

dpkg --configure <package> or the configure menu option in dselect: python-mode Python mode for GNU Emacs and XEmacs

I’ve issues with my system upgrade in my research I came across this partial fix: sudo apt-get install --reinstall python-minimal python-lockfile Partial Result is the: Install python-mode for ...
0
votes
2answers
120 views

Can't install Plantuml-mode — MELPA Package list Incomplete (Mac)

I'm trying to install plantuml-mode based on the instructions here: https://github.com/skuro/plantuml-mode I'm told to try the following: M-x package-install<RET> plantuml-mode<RET> ...
0
votes
1answer
47 views

How to install evil-snipe-enable-alternate-f-and-t-behaviors on Spacemacs?

I am trying to install "evil-snipe" with evil-snipe-enable-alternate-f-and-t-behaviors on Spacemacs. The instruction on https://github.com/syl20bnr/spacemacs/tree/master/layers/%2Bvim/evil-snipe are ...
0
votes
1answer
75 views

Installing Emacs from source: the command `C-h v` for accessing variables doesn't work

I have installed the latest development version of Emacs on my Mac from the source by cloning the Git repository here ('Emacs source repository' under 'Anonymous clone'), and then executing make in ...
1
vote
1answer
474 views

Installing Emacs from source: 'make' fatal error: 'libxml/tree.h' file not found

I wish to run Emacs from the latest development version. I've downloaded the latest Emacs development version from https://savannah.gnu.org/projects/emacs (with git clone -b master git://git.sv.gnu....
1
vote
1answer
129 views

Installing Emacs from source: no 'configure' file

I wish to build the latest development version of Emacs from source. I've browsed to https://savannah.gnu.org/projects/emacs and executed the command suggested on the front page, namely git clone -b ...
1
vote
1answer
621 views

How can I install Emacs25.2 on openSuse?

On Ubuntu I would install emacs dependencies with apt-get build-dep emacs24, extract the emacs25.2.tar.gz and install but the dependencies don't seem to be on openSuse's zypper (package manager). Atm ...
9
votes
2answers
1k views

eww ---> libxml2 library not found

Windows 10 (64 bit), Emacs 25.1. I try to open in Emacs some web page. E.g. www.google.com. So M-x eww Enter URL: www.google.com But I get error: libxml2 library not found
0
votes
0answers
728 views

How I can download the latest version of Emacs on Linux Mint 18.1?

Linux Mint 18.1 (64 bit). I install Emacs by Software Manager. It download Emacs version 24.5. But the latest version is 25.1. How I can download the latest version?
1
vote
1answer
215 views

emacs minimal install for Ubuntu server use

Is there a minimal version of emacs? When using apt get install emacs24 on a 16.04 LTS machine the packet manager propose me to install 200 MB worth of stuff... The following NEW packages will be ...
2
votes
1answer
968 views

What is the proper way to identify a font for .spacemacs file?

Spacemacs isn't finding my Source Code Pro font files, and I think it's a naming issue. I have the fonts installed and in the font cache, /usr/local/share$ fc-list : file | grep source Returns: /...
0
votes
1answer
623 views

libMagickWand-6.Q16.so.2 . . . No such file or directory

I just upgraded from Ubuntu 16.10 to 17.04, and now my Emacs (25.1.1), working fine before, is broken. Here is the error from running emacs --debug-init emacs: error while loading shared libraries: ...
0
votes
2answers
607 views

How to stop a minor mode from auto-loading in Spacemacs?

The smartparens minor mode is quite annoying to me, so I want to have it disabled on default. However, I don't want to uninstall it, in case I need it someday. Can I disable a minor mode without ...
1
vote
1answer
410 views

Why is the emacs-25.1-2 binary for Windows so big?

why is it so big? almost twice the size of 25.1 what's new with it?
4
votes
1answer
1k views

How to automatically install all packages loaded by my .emacs file in the minimum of lines?

My ~/.emacs (which you can find on GitHub) file loads several different Emacs packages and I would like them to be automatically installed as soon as Emacs starts up, if they are not already installed....
1
vote
0answers
214 views

Find All Dependencies Necessary for an Emacs Install Without X

I'm building a script to install a version of emacs (24.5 in this case) on a small server running on a raspberry pi. Since this will be in headless mode, I have no need for a GUI/X windows based ...
1
vote
1answer
75 views

Conflict in package installed with both package and el-get?

I list my packages: ;; List all packages installed with el-get-install (look for "installed" to find installed packages) (el-get-list-packages) ;; List packages installed with "package-install" (...
4
votes
3answers
1k views

Is it possible to install emacs 25.1 and emacs 24 on the same machine?

I currently have emacs 24.5.1 running on OSx el capitan. Since the first RC of emacs 25.1 released a few days ago, I am very curious to try it out. Can I have both versions installed on the same ...
3
votes
1answer
1k views

Location of Emacs' installation

Where is Emacs installed by default on Ubuntu? I need to find its path so I can use it on another application. I am using Ubuntu 14.04 and Emacs 24.
2
votes
1answer
395 views

ipython not working in org mode

I've followed everything here in order to set up ipython in org mode. But I keep getting the error: ...executing Ipython code block... apply: Searching for program: no such file or directory, ipython ...
2
votes
1answer
2k views

Emacs does not contain package “package”

I want to add C auto-completion at least so that I can use Emacs on a regular basis as my C editor. I am new to Emacs, and I had already it installed in my system, because it came with the OS (I think)...
2
votes
0answers
604 views

emacs-snapshot from Ubuntu PPA is currently totally broken [closed]

I have updated emacs-snapshot earlier today and it broke my Emacs installation into pieces (it is Ubuntu 14.04). It somehow removed whole emacs24 package so now I have no even emacs-client installed. ...
2
votes
1answer
307 views

Info files are found but not installed (on archlinux)

I am not able to access many info files. For example, the command (info "(gnus) Sorting the Summary Buffer") returns Info file gnus does not exist So I want to install/configure my info files ...
1
vote
2answers
108 views

Magit v2.2.0 failed to load: wrong type argument

After updating to magit v2.2.0 (and removing the old magit, git-rebase-mode and git-commit-mode I got the following error message after calling M-x magit-status: Wrong type argument: symbolp, (cyg . ...
9
votes
7answers
10k views

How can I have the latest version of emacs always

I love using Emacs and I want to have the latest version of Emacs always. But on my Ubuntu machine Emacs won't be upgraded automatically during the regular software updates. Even when I run sudo apt-...
1
vote
0answers
427 views

Installation Warning: Cannot convert string

I am installing emacs from source on Ubuntu machine. make install successfully installed it. Now when I start emacs it is showing this warning Warning: Cannot convert string "-*-courier-medium-r-*-*-...
6
votes
2answers
2k views

How to install a specific version of package?

When I do M-x package-install RET magit it installs the latest version of magit which is 2.1.0. I want to install magit 1.4.2. I don't want to do it manually by downloading and loading package. ...
4
votes
1answer
107 views

Install programs which require superuser permissions

I would like to, as part of Emacs Lisp package set-up process to run some programs which typically require superuser access, for instance, I would like to make sure that certain system packages are ...
7
votes
1answer
3k views

Create private spacemacs layer for yafolding

I had tried to create my first (private) layer for spacemacs, for the yafolding package. So I had created the ~/.emacs.d/private/yafolding/packages.el file with the following contents: (setq ...
6
votes
1answer
4k views

installing emacs: which x-toolkit?

I am installing Emacs 24.5.0, and I want to install it with X. I am on Fedora. the configuration script cannot find any x-toolkit. How do I find out which one is good for me, and in which folder do I ...
2
votes
2answers
345 views

default location to install ess not works with the self installed emacs

I am running Ubuntu 14.04. I don't use emacs from its repository. I installed my emacs by compling from source, the default location is /usr/local. e.g. /usr/local/bin/emacsand /usr/local/share/...
1
vote
2answers
833 views

Should I update or install emacs and related packages?

Emacs site says: The current stable release is 24.4 (released October 20, 2014; see also dates of older releases). I have installed it on my Ubuntu 14.04, by downloading the source from the emacs ...