Questions tagged [install]

The tag has no usage guidance.

18 questions with no upvoted or accepted answers
Filter by
Sorted by
Tagged with
3
votes
0answers
944 views

How to update Org-mode through Emacs' Package Manager?

I have org-version 9.1.9 installed and am attempting to install the latest version 9.2.2 I followed the instructions on https://orgmode.org/worg/org-faq.html#installing-via-elpa. On my system, M-x ...
2
votes
0answers
265 views

How to update Org-mode via Package Manager?

I have org-version 9.1.9 installed on Spacemacs and am attempting to install the latest org-version 9.2.6. Install instructions are on https://orgmode.org/worg/org-faq.html#installing-via-elpa and ...
2
votes
0answers
357 views

AUCTeX is obsolete on GNU ELPA?

I got this warning when installing AUCTeX from GNU ELPA. The package is installed, but I don't want to use obsolete packages for obvious reasons. I have check the official website of AUCTeX, and it ...
2
votes
0answers
63 views

Error when I try to re-install package after deleting it

I used package-install to install the pamparam package. It worked. But in playing with it, I got it into a weird state and decided to uninstall and re-install. I uninstalled by deleting its dir in ....
1
vote
1answer
46 views

Unable to install Eclim for Eclipse in emacs

$ sudo apt install eclipse eclipse-jdt Then, tried to install eclim using use-package in Emacs: (use-package eclim :ensure t :config (require 'eclim) (setq eclimd-autostart t) (defun ...
1
vote
0answers
496 views

Find All Dependencies Necessary for an Emacs Install Without X

I'm building a script to install a version of emacs (24.5 in this case) on a small server running on a raspberry pi. Since this will be in headless mode, I have no need for a GUI/X windows based ...
1
vote
0answers
524 views

Installation Warning: Cannot convert string

I am installing emacs from source on Ubuntu machine. make install successfully installed it. Now when I start emacs it is showing this warning Warning: Cannot convert string "-*-courier-medium-r-*-*-...
0
votes
0answers
39 views

running on the same Linux desktop two different emacs (and their emacsclient)

I would like to run two different emacs on the same Linux desktop (Debian/Sid/x86-64) running some XFCE4 desktop. The first is a latest emacs snapshot compiled from source code every morning (...
0
votes
0answers
12 views

ropemacs installation

I am trying to install ropemacs (https://github.com/python-rope/ropemacs) using: (require 'pymacs) (pymacs-load "ropemacs" "rope-") and did: pip install ropemacs Which gives me following error: ...
0
votes
0answers
204 views

Ubuntu, Doom Emacs: fails to run /bin/doom

I am trying to install Doom Emacs. I have installed all dependencies but when I run installation command I get this: ~/.emacs.d/bin/doom install Cannot open load file: No such file or directory, ...
0
votes
0answers
31 views

Install package issue - says disabled, doesn't auto-install dependencies

am relatively new user of emacs - and having a recurring problem that I'm sure has an easy solution, but I can't figure it out at all. Issue is: I use M-x package-install to install say org-ref. ...
0
votes
0answers
39 views

How to run multiple instances of Emacs with a different icon attached to each one of them?

It could be a solution for Plasma or Gnome Shell or Xfce or even a windows manager like i3 or bspwm. I am interested in the mechanism of how to do it - so any solution will suffice. For example, I ...
0
votes
0answers
91 views

Installing font package only once via command in file

I have a package that install the all-the-icons-package automatically namely (use-package zerodark-theme :ensure t :init (load-theme 'zerodark t) (zerodark-setup-modeline-format)) all-the-icons ...
0
votes
0answers
240 views

Downgrading Emacs in Fedora via 'dnf'

My problems with emacs 26-1 are discussed at this link : Emacs 26-1 Problems : find-file and neotree The following link discusses using dnf to installing a previous version of a package: https://unix....
0
votes
1answer
626 views

ESS install fails on Ubuntu 18.04

I had previously installed and used Emacs 25.2.2 and ESS 17.11 on Ubuntu 18.04 (Bionic Beaver). While attempting to update to the latest version of ESS, the ESS install script appears to have failed (...
0
votes
2answers
278 views

Can't install Plantuml-mode — MELPA Package list Incomplete (Mac)

I'm trying to install plantuml-mode based on the instructions here: https://github.com/skuro/plantuml-mode I'm told to try the following: M-x package-install<RET> plantuml-mode<RET> ...
0
votes
1answer
140 views

How to install evil-snipe-enable-alternate-f-and-t-behaviors on Spacemacs?

I am trying to install "evil-snipe" with evil-snipe-enable-alternate-f-and-t-behaviors on Spacemacs. The instruction on https://github.com/syl20bnr/spacemacs/tree/master/layers/%2Bvim/evil-snipe are ...
0
votes
0answers
1k views

How I can download the latest version of Emacs on Linux Mint 18.1?

Linux Mint 18.1 (64 bit). I install Emacs by Software Manager. It download Emacs version 24.5. But the latest version is 25.1. How I can download the latest version?