Skip to main content

Questions tagged [list-packages]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
0 votes
0 answers
44 views

How to programatically get a list of all packages that can be upgraded?

I'd like to write a function that returns a list of packages that can be upgraded. I know I can use list-package and then type U to search and list all packages that can be upgraded. But this is an ...
1 vote
1 answer
110 views

"Invalid version list `(4 5 -4 414)'" when running `M-x package-list-packages`

When following a suggestion for solving another problem, I'm doing M-x package-list-packages. However, that gives me the error message Invalid version list `(4 5 -4 414)'. What does this mean, and ...
0 votes
0 answers
5 views

Package dap-mode is dependency but shows no "Required By" and has not Delete button

After an install-orgie for lsp-mode experiment I would now like to uninstall packages again. A blocker is dap-mode. When looking through package-list-packages I find dap-mode, click on it and its *...
0 votes
0 answers
62 views

Emacs falsely recommends removal of explicitly installed packages - Why?

I am encountering a peculiar issue with Emacs's package management system where it is falsely recommending the removal of packages that I have explicitly installed via package-install. One such ...
0 votes
1 answer
107 views

Preventing loading of packages removed from Emacs's initialization file

Several packages continue to be available for use, even though I have removed them from init.el and restarted Emacs. However, this does not occur with emacs -Q. Previously, the persisting packages ...
0 votes
0 answers
64 views

How to open package list in emacs

The question is simple as Opening package list in emacs on macOS, I knew everywhere is Type M-x list-packages to open the package list., but it's just not working for me brew install emacs Start ...
1 vote
1 answer
149 views

Starting emacs with -Q lists the packages from my init file

For testing other issues I have, I start emacs with -Q, to avoid the probable errors in my init file. In that emacs session, running M-x package-list-packages still shows me all the packages that I ...
3 votes
3 answers
1k views

Emacs Contacting host: elpa.gnu.org:80 possibly related to TLS shenanigans

When I am trying to do M-x package-refresh-contents I get Contacting host: elpa.gnu.org:80 stuck until I do C-g. I tried to install a package and it didn't work through M-x package-install *...
0 votes
1 answer
71 views

Find unused packages installed from (m)elpa but also taking on-demand loaded packages into account

Because of playing around with some configurations I have a lot of unused but installed packages. Can I list them somehow to know which ones I can uninstall? The important point here is that not all ...
3 votes
0 answers
25 views

Problem with list-packages, package menu. Command / / removes my install I mark?

I do M-x list-packages. I want to install several packages, the first is beeminder. So I type / n beeminder RET to display the beeminder package. Great, I type i and it's marked for installation. ...
1 vote
0 answers
343 views

Package init and refresh problems

Due to unknown reason(s), the package manager in my Emacs 25.3 cannot refresh properly anymore: whenever I try to do M-x list-packages it throws an error: error in process filter: package-read-...
10 votes
2 answers
3k views

Error retrieving: https://elpa.gnu.org/packages/archive-contents (error http 400)

I am on this version of GNU Emacs on a Windows 10 computer: GNU Emacs 26.3 (build 1, x86_64-w64-mingw32) of 2019-08-29 For the past many weeks, Emacs report this error accessing GNU Elpa when I run &...
3 votes
1 answer
52 views

How to list a newly formed emacs minor-mode?

With some help from the blog post found here, I have managed to write a small code for a test package (a minor mode) named niranjan. It is as follows. (define-minor-mode niranjan-mode "Hello ...
0 votes
2 answers
665 views

How to filter the package list by package name part or regex

Via M-x list-packages I can view a list of installable and installed packages. Great! But how can I filter this list by a portion of the package name? PS: I know about package-menu-filter, but for me ...
2 votes
0 answers
263 views

Emacs warning after package updates

After running updates using list-packages, emacs keeps popping out the following messages when I open a tex file. I tried to reinstall the packages and commented out all settings related to auctex, ...
0 votes
1 answer
54 views

How to determine the size of packages installed from ELPA/MELPA?

When one wants to choose between two Emacs packages that have similar features, it can be useful to evaluate their respective installed size before installing. How to evaluate the installed size of a ...
6 votes
1 answer
652 views

list-packages hangs when contacting melpa

I'm running Emacs 26.3 on Linux Mint 20. I am using paradox, but this also happens when I use the vanilla Emacs packages interface. When I call list-packages, the Paradox Menu section of the mode line ...
0 votes
1 answer
27 views

Deleted package doesn't reappear in the package list

I just deleted magit, but it doesn't reappear in the list as available. I typed g and r, restarted emacs, to no effect. It's not hidden. I use C-s to search for it in the buffer. Supposedly its ...
0 votes
0 answers
260 views

package--check-signature-content error when running package-list-packages in Emacs 27

I recently upgraded to a GNU Emacs pretest 27 (version 27.0.91) running on MS Windows 10 platform. With package-check-signature defaulting to allow-unsigned, I modified init.el so Emacs can work ...
2 votes
0 answers
95 views

How to make list-packages Help for dependency package show the dependee packages?

I use use-package to require the boxquote package into my GNU Emacs 26.3 running on Ubuntu 19.10, like this: (use-package boxquote :ensure t) In the list-packages buffer, I see the boxquote ...
0 votes
1 answer
248 views

Melpa packages are not indexed before manually listing packages

I recently switched from sublime text 3 to emacs so I still don't quite understand everything. When I launch emacs and run package-install, I can not look up packages from Melpa to install, e.g., ...
0 votes
0 answers
111 views

list-packages has become very slow [duplicate]

After upgrading emacs from 24.4 to 26.3 on Windows, everything works fine except for one thing: the list-packages window has become horribly slow. Like, the cursor moves one second after the keystroke....
3 votes
3 answers
1k views

How to discover all available Emacs packages?

How can I discover all available packages of Emacs? So far, I was under the impression that I could find almost anything through one of these means: The Emacs Manual (C-h r) M-x list-packages C-h p ...
1 vote
3 answers
1k views

How to remove the remaining commands of removed built-in packages?

I've read here that you can delete the built-in packages from emacs at /usr/share/emacs/25.2/lisp in order to get rid of their commands which may clutter the minibuffer every time you want to execute ...
0 votes
2 answers
699 views

package is installed but command not available under M-x

I installed darkroom via the package manager in my GNU Emacs 25.3.1 (x86_64-w64-mingw32). M-x package-list shows the package as installed and in fact are the files in the respective folder, the ...
1 vote
2 answers
118 views

Why mark by "D" installed packages. I want only update it

Windows 10 (64 bit), Emacs 25.1 M-x package-list-packges I want to update all my installed packages. So I press "U". But Emacs mark many of installed package by "D". What does it mean? Is mean ...
2 votes
1 answer
230 views

Confusing ELPA types

When listing ELPA packages (Mac running Emacs 26.1), I see two status types that beg questions: dependency and incompat. A dependency package does get automagically loaded but it also may be removed ...
6 votes
2 answers
2k views

What does dependency mean in the Status field of a package shown in list-packages

The command list-packages shows the list of available packages. A Status column appears with several possible values: available installed dependency built-in incompat And the packages seem to be ...