Skip to main content

Questions tagged [list-packages]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
10 votes
2 answers

Error retrieving: (error http 400)

I am on this version of GNU Emacs on a Windows 10 computer: GNU Emacs 26.3 (build 1, x86_64-w64-mingw32) of 2019-08-29 For the past many weeks, Emacs report this error accessing GNU Elpa when I run &...
mobatemacs's user avatar
6 votes
2 answers

What does dependency mean in the Status field of a package shown in list-packages

The command list-packages shows the list of available packages. A Status column appears with several possible values: available installed dependency built-in incompat And the packages seem to be ...
nephewtom's user avatar
  • 2,271
6 votes
1 answer

list-packages hangs when contacting melpa

I'm running Emacs 26.3 on Linux Mint 20. I am using paradox, but this also happens when I use the vanilla Emacs packages interface. When I call list-packages, the Paradox Menu section of the mode line ...
MTS's user avatar
  • 377
3 votes
3 answers

Emacs Contacting host: possibly related to TLS shenanigans

When I am trying to do M-x package-refresh-contents I get Contacting host: stuck until I do C-g. I tried to install a package and it didn't work through M-x package-install *...
Jermog's user avatar
  • 81
3 votes
1 answer

How to list a newly formed emacs minor-mode?

With some help from the blog post found here, I have managed to write a small code for a test package (a minor mode) named niranjan. It is as follows. (define-minor-mode niranjan-mode "Hello ...
Niranjan's user avatar
  • 145
3 votes
3 answers

How to discover all available Emacs packages?

How can I discover all available packages of Emacs? So far, I was under the impression that I could find almost anything through one of these means: The Emacs Manual (C-h r) M-x list-packages C-h p ...
Gradient's user avatar
  • 211
3 votes
0 answers

Problem with list-packages, package menu. Command / / removes my install I mark?

I do M-x list-packages. I want to install several packages, the first is beeminder. So I type / n beeminder RET to display the beeminder package. Great, I type i and it's marked for installation. ...
CoolHandLouis's user avatar
2 votes
1 answer

Confusing ELPA types

When listing ELPA packages (Mac running Emacs 26.1), I see two status types that beg questions: dependency and incompat. A dependency package does get automagically loaded but it also may be removed ...
pajato0's user avatar
  • 399
2 votes
0 answers

Emacs warning after package updates

After running updates using list-packages, emacs keeps popping out the following messages when I open a tex file. I tried to reinstall the packages and commented out all settings related to auctex, ...
user50394's user avatar
  • 143
2 votes
0 answers

How to make list-packages Help for dependency package show the dependee packages?

I use use-package to require the boxquote package into my GNU Emacs 26.3 running on Ubuntu 19.10, like this: (use-package boxquote :ensure t) In the list-packages buffer, I see the boxquote ...
bgoodr's user avatar
  • 351
1 vote
2 answers

Why mark by "D" installed packages. I want only update it

Windows 10 (64 bit), Emacs 25.1 M-x package-list-packges I want to update all my installed packages. So I press "U". But Emacs mark many of installed package by "D". What does it mean? Is mean ...
a_subscriber's user avatar
  • 4,174
1 vote
3 answers

How to remove the remaining commands of removed built-in packages?

I've read here that you can delete the built-in packages from emacs at /usr/share/emacs/25.2/lisp in order to get rid of their commands which may clutter the minibuffer every time you want to execute ...
David von Tamar's user avatar
1 vote
1 answer

Starting emacs with -Q lists the packages from my init file

For testing other issues I have, I start emacs with -Q, to avoid the probable errors in my init file. In that emacs session, running M-x package-list-packages still shows me all the packages that I ...
Gauthier's user avatar
  • 509
1 vote
1 answer

"Invalid version list `(4 5 -4 414)'" when running `M-x package-list-packages`

When following a suggestion for solving another problem, I'm doing M-x package-list-packages. However, that gives me the error message Invalid version list `(4 5 -4 414)'. What does this mean, and ...
HelloGoodbye's user avatar
1 vote
0 answers

Package init and refresh problems

Due to unknown reason(s), the package manager in my Emacs 25.3 cannot refresh properly anymore: whenever I try to do M-x list-packages it throws an error: error in process filter: package-read-...
MLister's user avatar
  • 215
0 votes
1 answer

Preventing loading of packages removed from Emacs's initialization file

Several packages continue to be available for use, even though I have removed them from init.el and restarted Emacs. However, this does not occur with emacs -Q. Previously, the persisting packages ...
user avatar
0 votes
2 answers

How to filter the package list by package name part or regex

Via M-x list-packages I can view a list of installable and installed packages. Great! But how can I filter this list by a portion of the package name? PS: I know about package-menu-filter, but for me ...
halloleo's user avatar
  • 1,345
0 votes
1 answer

Deleted package doesn't reappear in the package list

I just deleted magit, but it doesn't reappear in the list as available. I typed g and r, restarted emacs, to no effect. It's not hidden. I use C-s to search for it in the buffer. Supposedly its ...
x-yuri's user avatar
  • 291
0 votes
2 answers

package is installed but command not available under M-x

I installed darkroom via the package manager in my GNU Emacs 25.3.1 (x86_64-w64-mingw32). M-x package-list shows the package as installed and in fact are the files in the respective folder, the ...
Nils's user avatar
  • 103
0 votes
1 answer

Find unused packages installed from (m)elpa but also taking on-demand loaded packages into account

Because of playing around with some configurations I have a lot of unused but installed packages. Can I list them somehow to know which ones I can uninstall? The important point here is that not all ...
buhtz's user avatar
  • 729
0 votes
1 answer

How to determine the size of packages installed from ELPA/MELPA?

When one wants to choose between two Emacs packages that have similar features, it can be useful to evaluate their respective installed size before installing. How to evaluate the installed size of a ...
Giuseppe's user avatar
  • 455
0 votes
0 answers

How to programatically get a list of all packages that can be upgraded?

I'd like to write a function that returns a list of packages that can be upgraded. I know I can use list-package and then type U to search and list all packages that can be upgraded. But this is an ...
PRouleau's user avatar
  • 821
0 votes
0 answers

Package dap-mode is dependency but shows no "Required By" and has not Delete button

After an install-orgie for lsp-mode experiment I would now like to uninstall packages again. A blocker is dap-mode. When looking through package-list-packages I find dap-mode, click on it and its *...
Harald's user avatar
  • 328
0 votes
0 answers

Emacs falsely recommends removal of explicitly installed packages - Why?

I am encountering a peculiar issue with Emacs's package management system where it is falsely recommending the removal of packages that I have explicitly installed via package-install. One such ...
Edman's user avatar
  • 1,229
0 votes
0 answers

How to open package list in emacs

The question is simple as Opening package list in emacs on macOS, I knew everywhere is Type M-x list-packages to open the package list., but it's just not working for me brew install emacs Start ...
http8086's user avatar
  • 101
0 votes
0 answers

package--check-signature-content error when running package-list-packages in Emacs 27

I recently upgraded to a GNU Emacs pretest 27 (version 27.0.91) running on MS Windows 10 platform. With package-check-signature defaulting to allow-unsigned, I modified init.el so Emacs can work ...
ash's user avatar
  • 9
0 votes
1 answer

Melpa packages are not indexed before manually listing packages

I recently switched from sublime text 3 to emacs so I still don't quite understand everything. When I launch emacs and run package-install, I can not look up packages from Melpa to install, e.g., ...
scribe's user avatar
  • 1,035
0 votes
0 answers

list-packages has become very slow [duplicate]

After upgrading emacs from 24.4 to 26.3 on Windows, everything works fine except for one thing: the list-packages window has become horribly slow. Like, the cursor moves one second after the keystroke....
Giovanni Gigante's user avatar