Skip to main content
Share Your Experience: Take the 2024 Developer Survey

Questions tagged [neotree]

NeoTree is an emacs tree plugin like NERD tree for Vim.

Filter by
Sorted by
Tagged with
0 votes
1 answer
47 views

Moving from VSCode: suggest a workflow that does not involve the tree view

I am considering moving from VScode to emacs, mostly motivated by the awesomeness of emacs; and by org-mode. But I am genuinely struggling to be comfortable without having a project tree view. How do ...
hyperio's user avatar
  • 155
0 votes
0 answers
163 views

how do i customize font faces and sizes in neotree buffer

I am trying to find a good folder view package to work alongside projectile and magit, I tried treemacs for a while and did not find it to my liking, I am now trying neotree. Neotree seems to be ...
Ajaneesh Rajashekharaiah's user avatar
0 votes
0 answers
601 views

Search file within neotree in an unexpanded directory

Is it possible to search a file in neotree which is deep inside some directory? The normal search only searches in the visible parts i.e., within directories that have been expanded. I am looking for ...
elexhobby's user avatar
  • 101
1 vote
0 answers
206 views

spacemacs opens file in terminal split

I'm using neotree and as you know it opens a file in the most recent window split you accessed before switching to neotree (window 0). Sometimes this last accessed split is the ansi-term window I ...
Asalle's user avatar
  • 113
0 votes
1 answer
354 views

Spacemacs: shortcut to jump from opened orgmode file to Neotree pane

I am using Spacemacs. So I have a Neotree pan that I open with Spc-f-t and that works fine. Then I can navigate down the tree to open a file with l and that will move the cursor from the Neotree pane ...
krishnab's user avatar
  • 519
1 vote
0 answers
484 views

neotree: `all-the-icons-icon-for-dir` raises void-function error

I am getting an error with neotree and i dont know why the arguments from call-interactively are nil. Edit: The Problem is within neotree and i have an empty init file just with neotree and the ...
mx400's user avatar
  • 11
1 vote
0 answers
489 views

Emacs 26-1 Problems : find-file and neotree

The Problems: I just did a full re-install to Fedora 29, which included the dnf install emacs command. This installed emacs 26-1; formerly I was using emacs 25.2. Formerly, my emacs initialization ...
zugzwang's user avatar
  • 319
0 votes
1 answer
430 views

How can I split the neotree window in spacemacs/emacs

I want my neotree window not to extend all the way to the bottom as shown here. How is that possible? If I try to split it I get an error saying the side window can't be split.
Chuck's user avatar
  • 1
2 votes
1 answer
1k views

how to rename a file in neotree without ivy select confusing? [duplicate]

I have this directory structure for example: /a/a1.txt I want rename /a/a1.txt to /a/a1, and hoping this result: /a/a1 But when I invoke C-c C-r command at the node of /a/a1.txt and input ...
LoranceChen's user avatar
0 votes
1 answer
994 views

Enter does nothing in NeoTree

I have NeoTree installed. When I navigate through folders and files in it and when I press enter, nothing happens. I don't get into a directory. I've tried TAB also -- nothing. M-x describe-key ...
Jorik's user avatar
  • 1
16 votes
2 answers
4k views

Neotree window not resizable

I get this message when I try to resize the neotree window using my mouse: No resizable window on the left of this one Does anyone know how I can make the neotree window re-sizable?
Rotareti's user avatar
  • 456
1 vote
0 answers
504 views

Set Neotree width by percentage?

I currently have this in my config file for neotree: ;(neotree-show) (setq neo-window-width 25) Does anyone know how I can set the window width to 25 percent?
Rotareti's user avatar
  • 456
2 votes
0 answers
89 views

Showing different project-trees in different instances of emacs daemon

At this point I usually hook up into my emacs-daemon using emacsclient -a "" -c "$@". When I also want to display my project using Neotree, this works well for only one instance but if I open a file ...
Boris's user avatar
  • 21
4 votes
3 answers
3k views

Stopping Neotree from constantly switching to the open file's directory?

I have the problem that, even when I'm in a projectile project, NeoTree always switches to the directory of the currently open file in the active buffer. Which is annoying to say the least. It used ...
Daniel Ziltener's user avatar
2 votes
1 answer
6k views

How can I set NeoTree to always show hidden files?

The only way i know to make NeoTree show hidden files is to use neotree-hidden-file-toggle, but this is meant to be used interactively when the NeoTree buffer is the active buffer. Is there a way to ...
eestrada's user avatar
  • 127