Questions tagged [package]

Emacs includes a facility that lets you easily download and install packages that implement additional features. Each package is a separate Emacs Lisp program, sometimes including other components such as an Info manual.

Filter by
Sorted by
Tagged with
0
votes
0answers
13 views

How can I reset the source code of an Emacs package to its original state?

Suppose I have installed company-0.9.13, which other packages depend on (mostly third-party company completion backends). I unwisely edited company-mode's source code directly in the ~/.emacs.d/elpa/...
0
votes
0answers
27 views

How to find the file-system location of a package?

Packages on my system are installed to ~/.config/emacs/elpa,although I assume it's possible to configure where packages are located. How can I programmatically find the file-path for a package name (...
0
votes
0answers
36 views

Getting uninstall packages offer after package updates

Each time I call up list-package and update, I get this message after the updates Operation finished. Packages that are no longer needed: 43. Type ‘M-x package-autoremove’ to remove them Below is ...
0
votes
0answers
22 views

How to force package-utils-upgrade-all to completely replace packages when upgrading?

lsp-mode doesn't support upgrading the package, instead, a full re-install is required each time (see report). (In my case, deleting the directory and re-installing works, upgrading doesn't). Is there ...
0
votes
0answers
19 views

How to force a package to upgrade, even if it's not needed?

I'm trying to debug a failure when a package is upgraded. The error only happens on update, not on re-installation. How could I upgrade a single package (e.g. package-utils-upgrade-by-name) and force ...
1
vote
1answer
138 views

nov-mode returns binary buffer and “File mode specification error: (error Invalid version syntax: ‘’ (must start with a number))”

When opening an epub file with Nov-mode I get a binary buffer in fundamental mode and an error message File mode specification error: (error Invalid version syntax: ‘’ (must start with a number)). ...
2
votes
1answer
65 views

Error when first launching Spacemacs in macOS 11.0.1

I am trying to learn Emacs. I successfully installed it and went through the built-in tutorial. I thought that installing Spacemacs would be nice so I gave it a try. I followed a tutorial and now I am ...
1
vote
0answers
68 views

Installing quelpa-use-package from use-package

Currently I have the following init file to install and use use-package: ;; Package.el (require 'package) (package-initialize) (setq package-enable-at-startup nil) (add-to-list 'package-archives '(&...
0
votes
0answers
33 views

Synchronize package list

When I look in the *Packages* buffer, I see this: polymode 20200411.915 available melpa Extensible framework for multiple major modes But, when I search for the same package on MELPA,...
1
vote
0answers
31 views

use-package & quelpa: resolve dependencies with elpa?

When modifying some packages I'm using (use-package :load-path "my-forked-project") but to make my config work in any machine I want get that package from say my github repo. I'm now trying ...
0
votes
1answer
26 views

clang-format package looking for wrong executable

I'm trying to setup emacs to use the clang-format package. I have installed the clang-format package from MELPA and also have clang-format-10 (apt install only installs version 6 on Ubuntu) installed ...
0
votes
2answers
79 views

package refresh hangs

On Emacs 26.3, Ubuntu 20.04, when I run emacs -Q followed by (package-refresh-contents) I get Contacting host: elpa.gnu.org:443 So the package refresh just hangs. I tried to switch from https to ...
0
votes
2answers
64 views

How to filter the package list by package name part or regex

Via M-x list-packages I can view a list of installable and installed packages. Great! But how can I filter this list by a portion of the package name? PS: I know about package-menu-filter, but for me ...
1
vote
0answers
30 views

Inconsistent behaviour with pretty outlines

SETUP: My .emacs.d/init.el reduced to the minimum (I have auctex and use-package installed) (require 'package) (add-to-list 'package-archives '("melpa" . "http://melpa.org/...
0
votes
1answer
42 views

package-installed-p vs fboundp

What should I use: (when (package-installed-p 'ivy) (global-set-key (kbd "C-x b") #'ivy-switch-buffer)) or: (when (fboundp 'ivy-switch-buffer) (global-set-key (kbd "C-x b") #'...
1
vote
1answer
74 views

How to disable remapping by a package

I recently used a package that overwrote C-x C-s to something other than save, causing me to lose a lot of work. Is there a way I can advise emacs to check for a blacklist of keybindings that it ...
1
vote
1answer
28 views

The number of downloads of packages in packages' repositories

On MELPA website, the number of downloads of each package is given. I am wondering if one can see this info within Emacs. It seems that the built-in package installer list-package does not provide ...
0
votes
1answer
21 views

How to determine the size of packages installed from ELPA/MELPA?

When one wants to choose between two Emacs packages that have similar features, it can be useful to evaluate their respective installed size before installing. How to evaluate the installed size of a ...
0
votes
0answers
74 views

How to delete/reinstall a system package?

When I do (require magit) I get following error. Debugger entered--Lisp error: (wrong-type-argument sequencep all) cl-intersection((all magit) all) byte-code("\301\302!\210\301\303!\210\301\...
0
votes
0answers
147 views

Emacs 27.1 package error while installing package org-roam

I recently upgraded to 27.1 version from 24.5 version. I am trying to install org-roam. When I use package-install RET org-roam, I am getting the following error. Library is file /usr/share/emacs/27.0....
0
votes
0answers
45 views

ad-Advice-package--add-to-archive-contents: Symbol's function definition is void: package-desc-vers

Friends, I have put strong effort to write an understandable account of the problem. Thus, I ask you to open all the site links quoted at the place of citation to follow the problem history. I have ...
4
votes
1answer
178 views

list-packages hangs when contacting melpa

I'm running Emacs 26.3 on Linux Mint 20. I am using paradox, but this also happens when I use the vanilla Emacs packages interface. When I call list-packages, the Paradox Menu section of the mode line ...
0
votes
0answers
13 views

Emacs package manager shows all melpa packages as “new” each time after restart

Since some time Emacs started to show each package that comes from "MELPA" repository as "new". It happens after each restart of Emacs. When I refresh package list in the same ...
0
votes
1answer
22 views

Deleted package doesn't reappear in the package list

I just deleted magit, but it doesn't reappear in the list as available. I typed g and r, restarted emacs, to no effect. It's not hidden. I use C-s to search for it in the buffer. Supposedly its ...
3
votes
1answer
612 views

package-selected-packages. What is it useful for?

What is the usefulness of setting (setq package-selected-packages '(auctex ; jedi ; magit ; etc)) Doesn't emacs set the user-installed ...
3
votes
0answers
32 views

What does it mean that something is an incompatible package?

I have some issues going on with my emacs and am getting an error where the stacktrace seems to indicate a potential issue with the parinfer package. I run describe-package on it and get parinfer is ...
1
vote
1answer
62 views

Emacs segfaults after I run M-x package-install

I'm a Emacs newbie. I've gone through the guided tutorial and I got excited by what Emacs promises. I want to learn Emacs and use it as my primary development editor, and specifically at the moment ...
0
votes
0answers
47 views

Jedi looking for emacs-26.1?

I just installed emacs 25 on Ubuntu (via apt install) and when I try to install jedi (after running package-refresh-contents) via package-install I'm getting the error message package-compute-...
0
votes
1answer
64 views

Trying to install org-ref package, but getting error 'emacs-25.1' unavailable

I am trying to install org-ref package but getting error package-compute-transaction: Package 'emacs-25.1' is unavailable. I searched Stack overflow, Stack Exchange Emacs, and github. I've found ...
0
votes
1answer
223 views

Using straight.el to develop your own package which is also on github

I am considering using straight.el, but reading the docs, I have difficulties to understand whether the particular use cases I am interested in are handled as I hope to. Here are the cases: I have ...
1
vote
0answers
45 views

Manually installed pdf-tools breaks package handling because it is not recognized as a dependency

The situation is: I install pdf-tools manually and load it with the following snippet: (use-package pdf-tools :pin manual :load-path "my/load/path/to/the/git/repo/lisp" :config .......
0
votes
0answers
30 views

Install a package just as in the `package-list-packages` menu

I am trying to install newer versions of org-mode in emacs 26.3. Obviously org mode 9.1.9 is already distributed with emacs. So any attempt to use the (package-install 'org) will not succeed. I have ...
0
votes
2answers
150 views

Initialization warning after installing doom-modeline

So recently i decided to switch to Emacs (btw I am total noob) and began creating my init.el file After downloading doom-modeline package from melpa and following it's installation guide I get an ...
0
votes
0answers
14 views

Any package for editing i18next locale files?

I am looking for a package that allows editing i18next locale files in emacs.
0
votes
0answers
59 views

I can't find the flycheck package

I am on MacOS and using Emacs 26.3 When I go to package-install in the minibuffer and type in flycheck, it autocompletes and adds a hyphen. I can't install just flycheck. Also when I go to list-...
0
votes
0answers
50 views

Can not install vue-mode on Emacs 25

I have emacs 25.2.2 on Ubuntu 18.04 I want to install vue-mode package. But I am getting this error message: vue-mode is an incompatible package. ...
10
votes
1answer
689 views

Getting started `use-package` question

I was reading the use-package documentation, which says, "Here is the simplest use-package declaration:" ;; This is only needed once, near the top of the file (eval-when-compile ;; Following line ...
2
votes
0answers
29 views

How to make list-packages Help for dependency package show the dependee packages?

I use use-package to require the boxquote package into my GNU Emacs 26.3 running on Ubuntu 19.10, like this: (use-package boxquote :ensure t) In the list-packages buffer, I see the boxquote ...
2
votes
1answer
222 views

Package for live inline rendering for markdown/org mode text with css styling?

Currently, I use Typora (a markdown editor) for all my personal notes and documentation. After seeing the capabilities of emacs in a colleague's spacemacs setup, I am very interested in switching from ...
0
votes
1answer
36 views

Emacs 24.3: warning “Unable to activate package”

Upon startup of my emacs 24.3, I'm getting the errors: Warning (emacs): Unable to activate package `with-editor'. Required package `emacs-24.4' is unavailable I have a dim recollection that when I ...
1
vote
0answers
101 views

reload emacs package in current session after .el source recompilation

I have an emacs package installed from elpa in my ${HOME}/.emacs.d/elpa/ directory, and I am trying to fiddle with its .el source file. I would like to recompile after modification have those ...
1
vote
1answer
1k views

A custom layer, org-roam, only works on the 3rd restart of spacemacs

I'm using Spacemacs v.0.200.13, and GNU Emacs 26.3 (build 2, x86_64-pc-linux-gnu, GTK+ Version 3.22.30) of 2019-09-16. I'd like to install and use the org-roam package. The instructions indicate ...
0
votes
0answers
44 views

why dash didn't show up with list-packages

I was trying to install dash using elpa but failed. I can't understand why it shows dash[no match] by following M-x package-install RET dash RET as in the snapshot. can anyone let me know why? Thank ...
0
votes
1answer
80 views

use-package: autoload function outside the main package file

I am trying to install simplenote2 to read my org files on my phone. The official setup method is: (require 'simplenote2) (setq simplenote2-email "email@example.com") (setq simplenote2-password "...
0
votes
1answer
32 views

Unattended install of a set of packages

Given a requirements.txt file describing a Python virtual environment, one can run pip install requirements.txt, go for a coffee, then come back to find that the packages in requirements.txt have been ...
0
votes
0answers
32 views

How could `(package-initialize)` affect the behavior of `org-open-at-point`?

Up until this afternoon, I was able to run org-open-at-point on something like [[file:/Users/apc/Desktop/test%20paper.pdf]] and open the file named "test paper.pdf" in my Desktop. But I'm no longer ...
1
vote
0answers
1k views

.emacs showing error “Wrong type argument: listp, closed” during start up

I am getting an error Wrong type argument: listp, closed while starting my Emacs. I tried to debug each line and do a M-x eval-buffer during configuration. At at time, it was showing only End of line ...
0
votes
1answer
92 views

install dependencies for emacs package in a CI environment

I am testing an Emacs package on Travis CI with ert. A PR now requires the s package. This is how I currently make sure it's available in the test environment: script: - $EMACS --version - $EMACS ...
1
vote
0answers
104 views

Unable to install a package

I am trying to add Magit to Emacs package list. I got as far as "Packages" menu and do not see how to add new, unlisted package. Is it even possible from Emacs ? I even tried to "i-install" ...
0
votes
0answers
108 views

How to run zone-matrix?

I found something that looks like fun: https://github.com/ober/zone-matrix A matrix-inspired EMACS screen saver. I need this in my life, but I can't (for the life of me) figure out how to get it to ...

1
2 3 4 5
9