Questions tagged [package-repositories]

for questions about repositories of Emacs packages on well-known servers, such as ELPA, MELPA, and Marmalade. Emacs uses library package.el to install and download updates to packages you choose.

Filter by
Sorted by
Tagged with
124
votes
4answers
16k views

What are the practical differences between the various Emacs Package Repositories?

I notice that there are several different repositories that often contain the same software. Why would I want to prefer: GNU ELPA Marmalade MELPA over the others? Since any one repository does not ...
28
votes
2answers
5k views

Do I still need GNU ELPA if I have MELPA?

This has always confused me, since people are saying that MELPA does have newer versions of packages, but it's not really clear, if GNU ELPA is just a subset of MELPA, or if I do need both? The ...
28
votes
2answers
4k views

Is it possible to use both MELPA and MELPA-stable at the same time?

I use melpa-stable as an additional package repository, but one of the packages I like to use (icicles) isn't available on melpa-stable. Is there any way to configure package.el to normally use melpa-...
21
votes
4answers
2k views

Easiest way to downgrade a package installed via MELPA

Sometimes, package updates from MELPA can break some part of emacs and when that happens I'd like to be able to revert back to using an older version of the package. Right now, I can do it in two ...
17
votes
2answers
9k views

The TLS connection was non-properly terminated

When running package-list-packages I get the following errors: Failed to download `gnu' archive. gnutls.c: [0] (Emacs) fatal error: The TLS connection was non-properly terminated. I am running Emacs ...
15
votes
2answers
775 views

How can I set up an ELPA server?

A buddy and I are wanting to start writing emacs packages specific for use in our company. (Trust me, nothing we write will be of much interest to anyone outside -- it's integration with internal ...
14
votes
4answers
1k views

What are the use cases of alternative package managers vis-à-vis `package.el`?

Background I use emacs daily, but mostly to get things done. I don't really like customising it more than adding packages and I don't like troubleshooting. I want emacs to fade into the background ...
14
votes
3answers
2k views

Dired+ missing from MELPA

I am trying to install dired+ from MELPA but it seems that it no longer is listed. I also checked here: https://melpa.org/ Is this normal?
14
votes
2answers
5k views

How to proceed on package.el signature check failure

I just tried to install ascii-art-to-unicode from the gnu repository (http://elpa.gnu.org/) via list-packages. I get the following error: package--check-signature: Failed to verify signature ...
12
votes
2answers
3k views

TLS connection to marmalade-repo.org:443 is insecure after updating to Emacs 25

When I run M-x list-packages I get the following error with Marmalade after updating to Emacs 25. Certificate information Issued by: COMODO RSA Domain Validation Secure Server CA Issued to: ...
10
votes
2answers
645 views

Technical considerations for package maintainers to not use the Emacs package manager?

I am noticing some notable package maintainers are choosing to not use the Emacs package management system (ESS?) or complaining about its limitations (Helm). Quoting from Helm's README.md: ...
10
votes
3answers
899 views

How to setup a private package repository?

I've written several packages for GNU Emacs, but they are useless outside of my company's environment. I want to be able to share the packages with other developers from my company. I also want the ...
10
votes
2answers
645 views

Install packages globallly

Is this something that can / should be done? For example, often I use emacs in my user account and sometimes root account. When using the package manager (i.e marmalade or something) do I have to ...
9
votes
3answers
801 views

How to generate and activate autoloads for local packages?

It is clear that not all local/custom/personal packages should be officially released, and it would be silly to do so just to benefit from built-in package management support. I'm wondering how to ...
7
votes
2answers
3k views

How to install a specific version of package?

When I do M-x package-install RET magit it installs the latest version of magit which is 2.1.0. I want to install magit 1.4.2. I don't want to do it manually by downloading and loading package. ...
6
votes
2answers
249 views

How to view package Full Description (commentary section) inside Emacs

I'm looking for a way to visualize inside Emacs the Full Description of a package as shown in Elpa index page. For example the undo-tree package has a nice and comprehensive help page/description ...
6
votes
1answer
2k views

How to add org-babel-execute function for plantuml?

I installed "PlantUML Mode for Emacs" using Melpa successfully, and I am able to switch to Plantuml-mode. However, when I try to evaluate code with C-c C-c, inside of org-mode, I get the error: org-...
6
votes
1answer
483 views

How do I set use-package-always-pin?

Emacs noob here, I want to use melpa-stable whenever possible for my packages. use-package has an option for this, use-package-always-pin. By default package.el prefers melpa over melpa-stable due ...
5
votes
1answer
2k views

How can I change the installation folder for Melpa packages?

I have just started using Melpa, and I installed the first package. The package though goes to the folder ~/Library/Preferences/Aquamacs Emacs/Pakcages/elpa/ but I would prefer if it went to my ....
5
votes
3answers
163 views

How to migrate snippets of scripts into my own packages?

While there are many docs on how to write packages, mirror your own package git repo's ... etc. This seems quite a heavy solution. What would be a good approach to having some local packages which ...
5
votes
1answer
1k views

How to use a theme installed with melpa?

I want to use this theme: https://github.com/jonnay/emagicians-starter-kit/blob/master/themes/org-beautify-theme.org I installed it via list-package successfully. I tried loading it via load-theme ...
4
votes
2answers
653 views

Fresh install of emacs 24.5.1 and Prelude not working because melpa wont download on OS X 10.11.2

I have a fresh install of Emacs 24.5.1 on OS X 10.11.2 and when I install prelude (https://github.com/bbatsov/prelude) via the recommended auto-magic way (curl -L https://git.io/epre | sh) then open ...
4
votes
2answers
642 views

Problems installing packages via elpa that require cl-lib-1.0

I'm having problems installing package from (m)elpa which require cl-lib-1.0. My emacs version is 24.3, hence I have a builtin copy of cl-lib-1.0, however, the only version available via elpa is 0.5. ...
4
votes
1answer
236 views

My init.el gets stuck on trying to install “spinner”, a sub-dependency of cider

I've installed emacs on a new machine (macos) brew cask install emacs. My init.el file gets stuck installing cider (clojure ide) because it requires "spinner". When I do: M-x package-refresh-contents, ...
4
votes
1answer
3k views

How do I work out what the problem is with the emacs package system?

I am trying to set up emacs (on cygwin / Win10) to handle JSON. I started with joshwnj/json-mode and was stoked to discover that emacs will now install its own dependencies from online repos. Fab ...
3
votes
2answers
568 views

Is .emacs.d portable across platforms?

I'm trying to use spacemacs (basically a thin layer with nice defaults around emacs) at work, but it wants to connect to elpa and melpa to download stuff - and is basically unusable without getting ...
3
votes
1answer
592 views

What is the standard way to install packages for Emacs?

There are several methods to install and manage packages for Emacs: package.el el-get use-package What is the easiest way to install package? It seems package.el ships with the default Emacs ...
3
votes
3answers
5k views

How to update Org to latest version using package repo's / git clone in Ubuntu

See the image below. . I want to update my org from Version: 2016071 to Version 20161003. It does not give me an option to upgrade when I use the package-list-packages command. An ...
3
votes
2answers
918 views

TLS connection to Melpa.org hanging on prelude

I've enabled some new packages in bbatsov's prelude and when I restart the emacs daemon, it hangs endlessly starting up showing this: Prelude is powering up... Be patient, Master g! Loading personal ...
3
votes
1answer
158 views

Is there a way to automatically install the relevant package when opening an unknown file type?

Is there an automated way to discover “well-known” packages related to a given file type, e.g. scala-mode2 for Scala files, rust-mode for Rust files, etc., and install them automatically when opening ...
3
votes
1answer
46 views

Is it normal for a package to request [sudo] in order to install a package? (this case pdf-tools) concerned about password integrity

I installed pdf-tools through MELPA, and then labels it as installed on a restart but kept viewing pdfs through doc-view. So using M-x pdf-tools-install it requested the sudo password in order to ...
3
votes
1answer
679 views

`org-bullets` - No longer needed

For a while, I've been getting the message Package menu: Operationfinished. 1 package no longer needed, type 'M-x package-autoremove' to remove them The package is org-bullets, very spread package ...
3
votes
1answer
99 views

use-package ensure not working: package downloaded but gives warning and skips config [duplicate]

I have the following code in my init.el file: (use-package org-plus-contrib :ensure t :config (progn (require 'ox-extra) (ox-extras-activate '(ignore-headlines)))) The :ensure t ...
3
votes
2answers
148 views

Can I load a single package from a different archive?

For my main package loading, I want to use melpa-stable. There's at least one package (dash) that I know breaks my config if I use the melpa version. That's fine - I've no problem using melpa-stable ...
3
votes
2answers
293 views

Keep spacemacs from retrieving package archives at startup

I'm trying to figure out a way to speed up my spacemacs start time. The main offender at the moment is the refreshing of package archives at start. I was hoping that setting dotspacemacs-check-for-...
3
votes
1answer
116 views

ELPA archives directory contents: the data structure used?

I just stumbled across the archives directory of my .emacs.d/archives/ . Here's the beginning of .../archives/gnu/archive-contents (1 (ace-window . [(0 9 0) ((avy (0 2 0)))...
3
votes
1answer
2k views

Emacs won't load theme installed from MELPA

I just installed the seti-theme from MELPA and no errors occurred. Than I ran M-x load-theme and after a few questions nothing would hapen and emacs would throw the following error: Warning (...
3
votes
1answer
153 views

Automatically move installed packages to site-lisp to benefit all user accounts

I have scripts to setup virtual machine images, where emacs packages are installed for the root account. Currently, I manually copy them to the appropriate site-lisp directory, i.e. one of those ...
3
votes
2answers
361 views

Fresh install 24.5 on Windows 10 bash shell Linux 16.04 crashing on package manager

Fairly new to emacs, seemed super awesome for writing a lot of different styles. Got it working just find on my desktop using the new bash terminal - 14.04 - on my desktop. Did the exact same setup ...
3
votes
1answer
342 views

Use system-installed package with spacemacs that depends on MELPA packages

How can I include a package that is available locally on my system that depends on the string library s with spacemacs? I have an company internal package that adds functionality to magit available ...
3
votes
1answer
339 views

Can't install elm-mode using MELPA

I'm trying to install elm-mode using MELPA. When I try to install it I get an error message: https://melpa.org/packages/dash-20150829.433.el: Not found I can install other things, bu not this.
2
votes
1answer
168 views

Transitioning to MELPA

It's time. I've spent too long with too many pieces of elisp lying around in site-lisp, outdated until I manually grab a new copy. I am new to the ELPA/MELPA/package.el/el-get world, but have ...
2
votes
3answers
4k views

How do I get MELPA working on my Windows 8 laptop

In my init file ~\AppData\Roaming\.emacs.d that I created using C-x C-f ~/.emacs.d/init.el RET I tried: (require 'package) ;; You might already have this line (add-to-list 'package-archives ...
2
votes
3answers
151 views

Autoload function or mode from ELPA

Use case I run my Emacs config on many machines. Most do not have a Racket installed, and I'd rather not have my Racket related packages installed by default. However, I would like to be able to edit ...
2
votes
2answers
149 views

How can I find the path of files in an (m)elpa package?

I wrote a minor mode for automatically detecting the language in which the user is typing. For this to work, I have to load some files containing language statistics. These files are in a ...
2
votes
1answer
55 views

emacs function to add include

When I edit C/C++ files time to time in the middle of buffer, I decide to add #include at the begin of buffer. Save position jump to begin of buffer, then insert suitable line, then jump back is ...
2
votes
1answer
55 views

Is there a package manager for emacs that can use git repositories directly?

Is there a way to manage packages in emacs where I can point to a git repository directly? (like vim-plug for eg).
2
votes
2answers
410 views

list-packages crashes Emacs 25.3 (Mac) when MELPA is added to .emacs

M-x list-packages crashes Emacs after I added: (add-to-list 'package-archives '("melpa" . "https://melpa.org/packages/")) after (package-initialize). (package-initialize) alone works ...
2
votes
1answer
551 views

Failed to download 'gnu' archive

I tried to install emacs and in an attempt to install MELPA, tried: (this is my init.el file) (package-initialize) (add-to-list 'package-archives '("gnu" . "http://elpa.gnu.org/packages/")) (add-to-...
2
votes
1answer
397 views

elpa certificate could not be verified

When I run package-list-packages, I'm getting an error: The TLS connection to elpa.gnu.org:443 is insecure for the following reason: certificate could not be verified I found a few other ...