Questions tagged [package-repositories]

for questions about repositories of Emacs packages on well-known servers, such as MELPA, GNU ELPA, and Marmalade. Emacs uses library package.el to download and install updates to packages you choose.

Filter by
Sorted by
Tagged with
3
votes
1answer
495 views

Can't install elm-mode using MELPA

I'm trying to install elm-mode using MELPA. When I try to install it I get an error message: https://melpa.org/packages/dash-20150829.433.el: Not found I can install other things, bu not this.
1
vote
2answers
227 views

How to deal with this message : IMPORTANT: please install Org from GNU ELPA as Org ELPA will close before Org 9.6

This message occur when I open an org file. I've put this in my init file : (require 'package) (add-to-list 'package-archives '("melpa" . "https://melpa.org/...
0
votes
2answers
76 views

HTTP Error 400 returned when accessing MELPA package archive

I'm working on a VM running Centos 7 which ships with emacs 24.3. I wanted to install, use some newer packages requiring > 25.1 so I downloaded the source for emacs 25.2 and built it. When I try to ...
3
votes
2answers
436 views

Fresh install 24.5 on Windows 10 bash shell Linux 16.04 crashing on package manager

Fairly new to emacs, seemed super awesome for writing a lot of different styles. Got it working just fine on my desktop using the new bash terminal - 14.04 - on my desktop. Did the exact same setup ...
0
votes
1answer
73 views

Melpa upgrade ignores url-proxy-service

I use Emacs in a corporate environment behind a proxy. I have customized url-proxy-services: '(url-proxy-services (quote (("http" . "proxy:3128") ("https" . &...
1
vote
0answers
32 views

Themes and other options not loading from MELPA

While following a tutorial on editing python using Emacs (https://realpython.com/emacs-the-best-python-editor/) I've been unable to install better-defaults, line numbers and any themes or return to ...
1
vote
1answer
58 views

Failed to download ‘melpa-stable’ archive. GnuTLS : Contacting host: 443

I am trying to install packages/modes from melpa on my emacs27.1, but I am unable to do so. If I run M-x package-refresh-contents , I get the following error : Importing package-keyring.gpg...done ...
3
votes
1answer
508 views

Use system-installed package with spacemacs that depends on MELPA packages

How can I include a package that is available locally on my system that depends on the string library s with spacemacs? I have an company internal package that adds functionality to magit available ...
3
votes
1answer
367 views

Debugging "Package lacks a file header"

I'm playing around with developing and publishing an Emacs package, very simple stuff, just trying things out before I commit to a bigger project. The problem that I'm having is that after I've made a ...
0
votes
2answers
382 views

Can't install Plantuml-mode -- MELPA Package list Incomplete (Mac)

I'm trying to install plantuml-mode based on the instructions here: https://github.com/skuro/plantuml-mode I'm told to try the following: M-x package-install<RET> plantuml-mode<RET> ...
0
votes
1answer
599 views

Right way of accessing MELPA repository

I am working on Debian 10 with Emacs installed from official Debian repositories (ver 1:26.1+1-3.2) and using the following code I cannot connect to synchronize packages available on MELPA: Here's my ...
0
votes
1answer
35 views

elpa package autoloads

I am having issues with autoloading of elpa packages under different versions of emacs (under macOS if that matters). My ~/.emacs.d is a link to somewhere else. Take as an example amx The loading ...
1
vote
2answers
366 views

Error with org-fstree: Symbol's function definition is void: reduce

I want to use the package org-fstree (MELPA Link). But in a file when I press C-c C-c at #+BEGIN_FSTREE: ~/ I get the following error: Symbol's function definition is void: reduce I am not sure ...
0
votes
1answer
175 views

Elpa + Melpa Certificate information issue at startup

I hadn't used Emacs for a few weeks and when I started it up I discovered issues with certificate information for elpa, melpa and orgmode. When I launch Emacs I get the following message: The TLS ...
0
votes
1answer
46 views

Spacemacs, using a package not found in melpa

I want to use the package ox-ipynb in spacemacs. I tried adding under dotspacemacs-additional-packages, but I guess since it's not on melpa, spacemacs couldn't find it. I've also tried downloading ...
4
votes
1answer
3k views

Getting error "Failed to download 'gnu' archive" on Emacs 26.3

I'm currently using Ubuntu 18.04, and trying out Emacs for the first time. However, whenever I run the command package-refresh-contents, I get the the follow error: Failed to download 'gnu' archive ...
0
votes
0answers
46 views

problem connecting to melpa packages

I'm new to emacs, and I'm having problems when trying to set up my init.el file to connect to the melpa packages site. I'm using MacOS Big Sur version 11.6, and Emacs version 26.2 (9.0) since there ...
3
votes
1answer
260 views

Melpa obsolete packages

Using Emacs 26.3, suddenly any package I install from Melpa shows Available Obsolete from melpa -- Install. All used to be fine. What is causing this?
6
votes
3answers
2k views

gpg fails to find key to elpa archive

I'm getting this error while trying download a package from ELPA: Failed to verify signature archive-contents.sig: No public key for 474F05837FBDEF9B created at 2018-11-28T14:10:03-0800 using DSA ...
4
votes
1answer
518 views

Error retrieving: https://elpa.gnu.org/packages/archive-contents

This is with the latest Emacs Version 27.2 (9.0) for Mac OS X: error in process sentinel: Error retrieving: https://elpa.gnu.org/packages/archive-contents (error connection-failed "connect" :...
0
votes
0answers
35 views

Spacemacs 0.300: installing only with zip and tar.gz archives offline?

OS: Windows 10 Emacs: 27.2 Spacemacs: 0.300 For some reasons, I cannot retrieve spacemacs through git (a complex combination of corporate proxy and other issues). But I can download archives. Being on ...
3
votes
1answer
3k views

Emacs won't load theme installed from MELPA

I just installed the seti-theme from MELPA and no errors occurred. Than I ran M-x load-theme and after a few questions nothing would hapen and emacs would throw the following error: Warning (...
0
votes
0answers
20 views

Melpa List of Packages is not complete despite refreshing

I am trying to set up Emacs from scratch for Common Lisp, as I want to learn both Emacs and Common Lisp in my spare time. I am having an issue with Emacs, and have been wrestling with it for a few ...
0
votes
2answers
78 views

"Failed to download ‘melpa’ archive" when I run package-refresh-contents

Have started seeing this error after I installed a new version of Emacs. My package code in init file is (require 'package) (setq package-archives '(("gnu" . "http://elpa.gnu.org/...
58
votes
9answers
29k views

How to proceed on package.el signature check failure

I just tried to install ascii-art-to-unicode from the gnu repository (http://elpa.gnu.org/) via list-packages. I get the following error: package--check-signature: Failed to verify signature ...
0
votes
0answers
18 views

Symbol’s value as variable is void: while-no-input-ignore-events

Every time I press M-x, the message Symbol’s value as variable is void: while-no-input-ignore-events appears Here is the output using $ emacs --debug-init Debugger entered--Lisp error: (file-error &...
2
votes
3answers
229 views

Connect to Melpa on Port 80 in Setup Script

I'm trying to setup emacs in a docker image that I am creating. I would like to create the image with a particular melpa package installed. This is my Dockerfile: FROM ubuntu RUN apt-get update RUN ...
4
votes
2answers
1k views

Cannot run melpa package refresh due to gpg errors

Root task: trying to install R mode for emacs (ESS following - https://stackoverflow.com/questions/1422987/emacs-mode-for-r) OS: Ubuntu 18.04 Problem: When I run M-x package-refresh-contents RET I get ...
1
vote
1answer
52 views

How can I handle unfound ELPA packages?

Sometimes I encounter packages claiming to be on ELPA, yet neither package-install nor [1] or [2] list them. How do I know if the problem is on my or the contributor's side? Simply manually installing ...
1
vote
2answers
58 views

Are all .el files inside ELPA compliant packages sharing the same namespace?

Assuming that a ELPA directory contains only one version of each Elpa-compliant packages, are the names of all Emacs Lisp files sharing the same namespace? AFAIK Emacs Lisp does not support the ...
0
votes
1answer
44 views

Do MELPA packages get updated automatically?

The website says they do: Automatic updates - new commits result in new packages But I ask because if I go M-x list-packages and hit U there are many upgrades available for packages under the "...
0
votes
0answers
54 views

Make emacs aware of kerberos authentication

I have trouble installing my environment at work. The only accepted method of authentication for accessing the internet is via kerberos. My credentials are provided, the server (proxy) with its port ...
0
votes
1answer
58 views

Why not store all .el/.elc Elpa files inside the same directory to speed up Emacs startup?

Would it not be possible to modify Emacs package system to store all Emacs Lisp files installed from Elpa-compliant packages inside the same directory? That would dramatically reduce the number of ...
0
votes
1answer
103 views

Why does setting use-package-always-ensure cause Emacs to contact package repositories at startup?

I have the following in my init.el: (setq use-package-always-ensure t) because I want packages referenced by use-package to be downloaded automatically if I don't have them. When I enable this ...
0
votes
1answer
72 views

Search ELPA/MELPA Package repositories

I know searching for packages in the ELPA/MELPA repositories might be available within emacs itself, but I'm just wondering, can I do the search on the Internet as well? Just like I know I can search ...
1
vote
1answer
91 views

Why this "keybinding conflicts" message keeps appearing? How can I fix it?

After pressing M-x sly, I keep receiving this message: [sly] SLIME detected in 'lisp-mode-hook', causes keybinding conflicts. Remove it for this Emacs session? The odd thing is that SLIME is not ...
1
vote
0answers
48 views

Cannot load some modes via elpa

Some of my major modes, installed via ELPA, error during load as, for instance for markdown-mode, Debugger entered--Lisp error: (file-missing "Cannot open load file" "No such file or ...
1
vote
0answers
225 views

Packages are broken

Almost any time I try to use packages, they fail for one reason or another. I did manage to install a package some time last year (2020) but not since. The marmalade-repo.org has had a bad certificate ...
0
votes
1answer
25 views

Trying to install scad-mode from package repository

This melpa.org page suggests that the scad-mode package is installable from a package repository. But I tried adding http://marmalade-repo.org/ to my package archives, but scad-mode still doesn't show ...
1
vote
0answers
24 views

show which package repo was used to obtain a package

I'm trying to submit a bug report to emacs-evil, and they ask me from which repo evil was installed. I'm just using the version that came bundled with doom-emacs. How can I know which source was used ...
4
votes
1answer
729 views

How do I solve `Lisp error: (void-function -compose)` when using lsp-dart?

When I load a Dart file with GNU Emacs 27.1-1 for OS X I get the following little error novel. Debugger entered--Lisp error: (void-function -compose) (-compose #'lsp--client-path->uri-fn #'lsp--...
3
votes
2answers
4k views

Why am I getting an error while downloading Melpa packages in Emacs on Win7 OS

I am using Emacs on a Win7 machine. I have added the Melpa repo. in init.el. When I do M-x list-packages, I do get a buffer listing the packages from Melpa. But, when i try to download them, I get an ...
16
votes
3answers
5k views

TLS connection to marmalade-repo.org:443 is insecure after updating to Emacs 25

When I run M-x list-packages I get the following error with Marmalade after updating to Emacs 25. Certificate information Issued by: COMODO RSA Domain Validation Secure Server CA Issued to: ...
0
votes
0answers
71 views

Incompatible Packages w/ 26.3 and MELPA

I know I must be missing something simple, but I've recently upgraded my Linux OS to Mate 20.04. As a result, my version of emacs is Emacs 26.3. I'm now running into incompatibility issues with MELPA ...
0
votes
2answers
910 views

Cannot access ELPA from Emacs behind a corporate proxy (Mac)

I'm having trouble accessing ELPA on my Mac from behind a corporate proxy. Emacs 27.1. I have http_proxy and https_proxy configured appropriately (I've also tried setting url-proxy-services). From ...
0
votes
0answers
307 views

Disable package refreshing when starting emacs

I have bad internet connection. Starting spacemacs takes a long time because of the "refreshing package archive melpa or gnu or others...". or "installing package: ...". When i ...
9
votes
2answers
3k views

Error retrieving: https://elpa.gnu.org/packages/archive-contents (error http 400)

I am on this version of GNU Emacs on a Windows 10 computer: GNU Emacs 26.3 (build 1, x86_64-w64-mingw32) of 2019-08-29 For the past many weeks, Emacs report this error accessing GNU Elpa when I run &...
2
votes
1answer
141 views

Error when first launching Spacemacs in macOS 11.0.1

I am trying to learn Emacs. I successfully installed it and went through the built-in tutorial. I thought that installing Spacemacs would be nice so I gave it a try. I followed a tutorial and now I am ...
37
votes
2answers
9k views

Do I still need GNU ELPA if I have MELPA?

This has always confused me, since people are saying that MELPA does have newer versions of packages, but it's not really clear, if GNU ELPA is just a subset of MELPA, or if I do need both? The ...
11
votes
1answer
1k views

How do I fix "incomprehensible buffer" error when running list-packages?

When running list-packages in emacs on an up-to-date Debian Buster (10.6) I get the following error: error in process sentinel: Error retrieving: https://stable.melpa.org/packages/archive-contents &...